Ask Your Question
0

rosserial arduino rosmake error

asked 2012-01-19 17:37:35 -0500

byanana gravatar image

Hi there,

I'm new to Arduino and ROS, and I am currently trying to install the rosserial arduino in mac. I've installed homebrew and done everything in this page.

When I try installing the rosserial for Arduino IDE, I got an error for

rosdep install rosserial_arduino

the error was:

rosdep: error: No Valid Packages or stacks listed as arguments

I tried the solution here but when I did the

rosmake rosserial_arduino

I got an error saying:

[rosmake] WARNING: The following args could not be parsed as stacks or packages: ['rosserial_arduino']
[rosmake] ERROR: No arguments could be parsed into valid package or stack names

And sure enough when I check the Arduino IDE I still couldn't find the ros_lib in the Examples menu.

Please help me with this problem. Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2012-01-19 18:11:50 -0500

updated 2012-01-19 18:12:26 -0500

This sounds a lot like your ROS_PACKAGE_PATH environment variable is not set correctly. Are you sure your 'rosserial_arduino' package is inside a directory that is known to ROS via ROS_PACKAGE_PATH as described here?

edit flag offensive delete link more

Comments

Hi, I've tried setting the ROS_PACKAGE_PATH as describe in your link (export ROS_PACKAGE_PATH=/home/user/ros/ros-pkg) however when I was trying this http://www.ros.org/wiki/ROS/Tutorials/InstallingandConfiguringROSEnvironment, when I get to the 2nd step (the source one) it says No such file or dir
byanana gravatar imagebyanana ( 2012-01-23 09:31:38 -0500 )edit
Also I seem to be able to get the rosdep command working. However I cannot install gcc-avr. anyone know why?
byanana gravatar imagebyanana ( 2012-01-23 11:09:59 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2012-01-19 17:37:35 -0500

Seen: 696 times

Last updated: Jan 19 '12