ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

urdf parsing error

asked 2014-02-03 06:39:19 -0500

mudassar gravatar image

updated 2014-02-09 20:51:54 -0500

gvdhoorn gravatar image

In tutorial :

When I run:

~/catkin_ws$ ./devel/lib/testbot_description/parser /src/testbot_description/urdf/my_robot.urdf

I get:

[ERROR] [1391452425.205963339]: Could not open file [/src/testbot_description/urdf/my_robot.urdf] for parsing.
[ERROR] [1391452425.206094879]: Failed to parse urdf file

I checked in the directories, both files are already present but still error! Kindly help!

My Ros: Hydro My OS: Ubuntu 12.04 LTS

edit retag flag offensive close merge delete


what do you see when you run "ls /src/testbot_description/urdf/my_robot.urdf"?

hsu gravatar image hsu  ( 2014-02-03 09:17:59 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2014-02-09 02:08:55 -0500

mudassar gravatar image

There is a dot missing in the second tutorial.

From your catkin workspace, run: ./devel/lib/testbot_description/parser ./src/testbot_description/urdf/my_robot.urdf

It worked for me.

edit flag offensive delete link more

answered 2014-02-03 07:45:35 -0500

dsolomon gravatar image

urdf::Model::initFile(urdf_file) takes an absolute file path (see urdf::Model C++ API), so you would have to run something like ./devel/lib/testbot_description/parser /home/<user>/catkin_ws/src/testbot_description/urdf/my_robot.urdf (make sure to replace <user> with your user name).</user></user>

edit flag offensive delete link more


Still not working for me. An error of more or less the same type appears!

mudassar gravatar image mudassar  ( 2014-02-03 08:48:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2014-02-03 06:39:19 -0500

Seen: 1,177 times

Last updated: Feb 09 '14