Ask Your Question
0

rviz crash on adding obstacles from local_costmap [closed]

asked 2014-01-30 13:03:46 -0600

BP gravatar image

updated 2014-02-05 05:53:53 -0600

I have rviz crash

[rviz-5] process has died [pid 26833, exit code -11, cmd /opt/ros/groovy/lib/rviz/rviz -d /home/user/catkin_ws/src/semantic_navigation/rviz_config_test.rviz __name:=rviz __log:=/home/user/.ros/log/b2dfc712-8a10-11e3-b737-3c970e43a294/rviz-5.log].

when I try to add GridCells: topic: move_base_node/local_costmap/anything from here eg. obstacles

my parameters:

local_costmap:
publish_voxel_map: true
global_frame: /odom
robot_base_frame: /base_link
update_frequency: 5.0
publish_frequency: 5.0
static_map: false
rolling_window: true
width: 15.0
height: 15.0
resolution: 0.05
origin_x: 0.0
origin_y: 0.0

edit 1: LaserScan also crashes rviz

edit 2: I run rviz with optirun and the error does not occure when adding LaserScan, but error from local_costmap remains.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by BP
close date 2014-03-19 14:01:49

Comments

Same problem started to happen to me this week. While visualizing the navigation in Rviz, it crashes and sometimes (not always) says "malloc(): memory corruption". More Info: ubuntu 12.04, ros groovy, rviz version 1.9.34 , OGRE version 1.7.4, OpenGl version: 4.2. Nvidia driver 304.116 (Quadro 600)

Ander gravatar image Ander  ( 2014-01-30 20:15:27 -0600 )edit

I'm getting new segfaults from trying to display LaserScan messages in Rviz too. Was working well last week. rviz version 1.9.34. OGRE version 1.7.4 (Cthugha). OpenGl version: 3 (GLSL 1.3). Intel Hashwell Video driver. Works well in Hydro still! Just not Groovy.

Angus gravatar image Angus  ( 2014-01-31 06:13:01 -0600 )edit

Today I made another test. Instead of using the rviz binary installed with groovy distro, I downloaded the source code of rviz groovy-devel branch from github, built it and, after running, same problem happens: Segmentation fault (core dumped).

Ander gravatar image Ander  ( 2014-02-02 21:30:56 -0600 )edit

I'm also getting errors while trying to display LaserScan

BP gravatar image BP  ( 2014-02-03 03:46:00 -0600 )edit

I also have the same problem on my new PC with Intel i7 Haswell. Rviz crashes after showing the laserscan message. PS: I have the same configuration of Angus (RVIZ 1.9.34. OGRE 1.7.4 OpenGl 3 (GLSL 1.3). Intel Hashwell Video driver.

oleo80 gravatar image oleo80  ( 2014-02-03 05:03:47 -0600 )edit

https://github.com/ros-visualization/rviz/issues/713

BP gravatar image BP  ( 2014-02-03 11:39:26 -0600 )edit

i've updated question and added how i got rviz to work with LaserScan

BP gravatar image BP  ( 2014-02-05 05:54:55 -0600 )edit

I downloaded previous rviz versions in order to figure out which is the last version that works. With rviz 1.9.32 I have no problems at all. After this version, both 1.9.33 and 1.9.34 crash.

Ander gravatar image Ander  ( 2014-02-05 22:13:02 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-02-27 04:03:51 -0600

I installed rviz1.9.35 from https://github.com/ros-visualization/... and rviz don't crash anymore when I add LaserScan

edit flag offensive delete link more

Comments

finally did it, i had problem with yaml. I end up with 1.9.32 working properly.

BP gravatar image BP  ( 2014-03-19 14:01:26 -0600 )edit

@Gargamel, could You please elaborate more on Your exact problem and solution, please?

Kamiccolo gravatar image Kamiccolo  ( 2014-03-27 04:28:44 -0600 )edit
BP gravatar image BP  ( 2014-03-27 05:08:30 -0600 )edit

@Gargamel, oh, ok, thanks. Waiting for the fixed version to appear in repository :}

Kamiccolo gravatar image Kamiccolo  ( 2014-03-27 05:20:36 -0600 )edit

there is (not in ubuntu's propably, but on github). You can download old working (1.9.32) or new working (1.9.35) version (If you're groovy user) and build it from source ( I had problems with old YAML libraries linking but building new rviz in debug worked for me-dunno why)

BP gravatar image BP  ( 2014-03-27 06:07:22 -0600 )edit

Question Tools

3 followers

Stats

Asked: 2014-01-30 13:03:46 -0600

Seen: 1,269 times

Last updated: Feb 27 '14