ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
1

Why is eclipse complaining about links?

asked 2011-12-14 12:49:15 -0500

tperkins gravatar image

updated 2014-01-28 17:11:00 -0500

ngrennan gravatar image

I'm trying to open costmap_2d in eclipse, but I get the following error when trying to import:

Error processing changed links in project description file. Cannot create a link to '/home/tim/ros_source/electric/navigation/costmap_2d' because it overlaps the location of the project that contains the linked resource.

I have no idea what this means. I get similar errors for all other packages.

I have a fresh install of Ubuntu 11.10. I've successfully built ROS from source. I have eclipse indigo for c/c++ developers. Here's what I'm doing:

  1. rosmake costmap_2d
  2. make eclipse-project
  3. open eclipse
  4. Import... > General > Existing project
  5. Browse to /home/tim/ros_source/electric/ros_comm/clients/cpp/roscpp
  6. don't select copy into workspace, press finish
  7. error

The project seems to get partially imported, but it's pretty manged.


The manged project has some issues. They might be related, or they may just be a side effect.

Invalid project path: Include path not found (/home/tim/ros_source/electric/driver_common/dynamic_reconfigure/msg/cpp).

Invalid project path: Include path not found (/home/tim/ros_source/electric/driver_common/dynamic_reconfigure/srv/cpp).

Invalid project path: Include path not found (/home/tim/ros_source/electric/ros/core/roslib/msg_gen/cpp/include).

The first two seems a little weird, shouldn't those be msg_gen/cpp/include and srv_gen/cpp/include?

I'm also confused on the third one, because roslib doesn't generate messages, right?

edit retag flag offensive close merge delete

Comments

This seems to be a problem of the directory tree and is rather Eclipse related, I'd look for solutions elsewhere, like on stackoverflow. http://lmgtfy.com/?q=because+it+overlaps+the+location+of+the+project+that+contains+the+linked+resource
tom gravatar imagetom ( 2011-12-14 19:52:31 -0500 )edit
Yeah I agree, it's an eclipse problem. But I posted it here because I image other developers are seeing the same thing, given I have a fresh install (and I haven't done anything weird, I promise). And if I figure it out myself, I can answer my own question.
tperkins gravatar imagetperkins ( 2011-12-15 13:49:02 -0500 )edit
BTW, try posting a constructive comment next time. Do you honestly think I haven't already googled it?
tperkins gravatar imagetperkins ( 2011-12-15 13:54:08 -0500 )edit
Don't feel offended, please. You haven't written what solutions you already tried, which one normally should do if had tried any.
tom gravatar imagetom ( 2011-12-15 18:45:55 -0500 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2011-12-16 07:31:55 -0500

AHornung gravatar image

The warnings are a result of packages exporting a non-existing paths in their manifest, see these previous discussions on ros-users:

http://ros-users.122217.n3.nabble.com/ROS-Eclipse-warnings-td2479833.html

http://ros-users.122217.n3.nabble.com/Please-remove-references-to-msg-cpp-and-srv-cpp-from-package-manifests-td2168967.html#a2170278

Packages still exporting these paths should be ticketed for a fix (they just need to remove the non-existant include path from the manifest). That being said, I don't think it's related to your first problem. I have seen plently of these warnings using Eclipse, but never your first error.

edit flag offensive delete link more

Comments

This doesn't seem to fix the issue. The first error still persists for me when trying to work on the slam_gmapping package.

FranciscoD gravatar imageFranciscoD ( 2013-09-03 23:12:28 -0500 )edit

http://stackoverflow.com/questions/7000562/eclipse-cannot-create-a-link-to-dir-generated-by-cmake says it's because of the build directory, but the ros wiki page says that the make command should take care of this itself http://wiki.ros.org/IDEs#Creating_the_Eclipse_project_files

FranciscoD gravatar imageFranciscoD ( 2013-09-03 23:13:49 -0500 )edit
1

answered 2012-02-29 02:12:37 -0500

felix k gravatar image

Just in case someone has a similiar problem, I had to adjust/conform the CMakeLists.txt to get eclipse import a package.

Compared to the active lines of a usual CMakeLists.txt, the on from that package was missing following lines, which might have disturbed eclipse as project and bin folder would be the same.

#set the default path for built executables to the "bin" directory
set(EXECUTABLE_OUTPUT_PATH ${PROJECT_SOURCE_DIR}/bin)
#set the default path for built libraries to the "lib" directory
set(LIBRARY_OUTPUT_PATH ${PROJECT_SOURCE_DIR}/lib)
edit flag offensive delete link more

Comments

I had imported costmap_2d package standard Eclipse way and it works out of box. CMakeList do not contain above mentioned lines. I believe more deep inspection is required for this problem. I am using diamondback on Eclipse Indigo on Ubuntu10.04.

prince gravatar imageprince ( 2012-02-29 21:12:54 -0500 )edit

Thanks @felix, adding these lines solved the problem for me.

Martin Günther gravatar imageMartin Günther ( 2012-11-14 00:30:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-12-14 12:49:15 -0500

Seen: 2,612 times

Last updated: Feb 29 '12