ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
0

"rosdep update" broken after ubuntu 12.04.04 amd64 ros-groovy-* updates.

asked 2014-01-27 06:03:12 -0600

Kamiccolo gravatar image

updated 2014-02-04 01:04:28 -0600

After updating ros-groovy-* packages from official precise repository found out that rosdep is broken.

Terminal:

$ rosdep update

reading in sources list data from /etc/ros/rosdep/sources.list.d
Hit  <a href="https://github.com/ros/rosdistro/raw/master/rosdep/osx-homebrew.yaml">https://github.com/ros/rosdistro/raw/...</a> 
Hit  <a href="https://github.com/ros/rosdistro/raw/master/rosdep/gentoo.yaml">https://github.com/ros/rosdistro/raw/...</a> 
Hit  <a href="https://github.com/ros/rosdistro/raw/master/rosdep/base.yaml">https://github.com/ros/rosdistro/raw/...</a> 
Hit  <a href="https://github.com/ros/rosdistro/raw/master/rosdep/python.yaml">https://github.com/ros/rosdistro/raw/...</a> 
Hit  <a href="https://github.com/ros/rosdistro/raw/master/rosdep/ruby.yaml">https://github.com/ros/rosdistro/raw/...</a> 
Hit  <a href="https://github.com/ros/rosdistro/raw/master/releases/fuerte.yaml">https://github.com/ros/rosdistro/raw/...</a> 
Query rosdistro index  <a href="https://raw.github.com/ros/rosdistro/master/index.yaml">https://raw.github.com/ros/rosdistro/...</a> 

ERROR: Rosdep experienced an error: Unable to handle 'index' format version '2', please update rosdistro

Please go to the rosdep page [1] and file a bug report with the stack trace below.
[1] :  <a href="http://www.ros.org/wiki/rosdep">http://www.ros.org/wiki/rosdep</a> 


rosdep version: 0.10.21

Traceback (most recent call last):

File "/usr/local/lib/python2.7/dist-packages/rosdep2/main.py", line 118, in rosdep_main 
    exit_code = _rosdep_main(args)

File "/usr/local/lib/python2.7/dist-packages/rosdep2/main.py", line 261, in _rosdep_main
    return _no_args_handler(command, parser, options, args)

File "/usr/local/lib/python2.7/dist-packages/rosdep2/main.py", line 269, in _no_args_handler
    return command_handlers[command](options)

File "/usr/local/lib/python2.7/dist-packages/rosdep2/main.py", line 434, in command_update
    error_handler=update_error_handler)

File "/usr/local/lib/python2.7/dist-packages/rosdep2/sources_list.py", line 422, in update_sources_list
    for d, dist in get_index().distributions.iteritems():

File "/usr/local/lib/python2.7/dist-packages/rosdep2/rosdistrohelper.py", line 58, in get_index
    _RDCache.index = rosdistro.get_index(_RDCache.index_url)

File "/usr/local/lib/python2.7/dist-packages/rosdistro/__init__.py", line 106, in get_index
    return Index(data, base_url)

File "/usr/local/lib/python2.7/dist-packages/rosdistro/index.py", line 51, in __init__
    assert int(data['version']) == 1, "Unable to handle '%s' format version '%d',       
please update rosdistro" % (Index._type, int(data['version']))

AssertionError: Unable to handle 'index' format version '2', please update
    rosdistro

The thing which actually bugs me, that $ dpkg -s python rosdep reports:

Package: python-rosdep
Source: rosdep
Version: 0.10.25-1

BUT $ rosdep --version , &gt;&gt;&gt; pkg_resources.get_distribution("rosdep").version and $ pip search rosdep returns 0.10.21 as installed version.

Any ideas, how to fix this thing?

I've already tried re-sourcing setup.bash on another terminal and reinining deps. Do not think that reinstalling whole damn thing is the nicest solution pinning the problem down to it's roots.

EDIT

Another weird thing: $ which rosdep returns /usr/local/bin/rosdep, but trucated $ dpkg -L python-rosdep ... (more)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-01-27 07:31:44 -0600

tfoote gravatar image

The /usr/local location is your problem. You have a pip based installation overlaying your debian packages. You need to invoke pip uninstall repeatedly until it is removed, similarly to this answer. http://answers.ros.org/question/49143/problems-with-rqt-groovy-ubuntu

edit flag offensive delete link more

Comments

Tried that, didn't work. `sudo pip uninstall rosdep` and `sudo pip search rosdep` told, that same `rosdep 0.10.21` version is **STILL** installed. And, as I told, setting up the ROS environment, `pip` on my side was not used at all. Only thing which was installed using `pip` was `YAML` library. Ages ago. Which was actually updated too.

Kamiccolo gravatar image Kamiccolo  ( 2014-01-27 07:39:14 -0600 )edit

Did you uninstall it multiple times as explained in the link?

tfoote gravatar image tfoote  ( 2014-01-27 09:43:15 -0600 )edit

@tfoote, yes, I did. Unfortunetly, it didn't make any difference at all. I've also tried `pip freeze | xargs pip uninstall -y` (as suggested in http://stackoverflow.com/a/20385069/1150918 ), still - no change at all.

Kamiccolo gravatar image Kamiccolo  ( 2014-01-28 04:48:55 -0600 )edit

Can you edit your question so show your command and output when you try to uninstall?

tfoote gravatar image tfoote  ( 2014-01-28 05:22:04 -0600 )edit
0

answered 2014-01-27 07:27:02 -0600

Kamiccolo gravatar image

updated 2014-01-27 07:30:17 -0600

$ sudo pip install --upgrade rosdep fixes the problem, even thought all ros-groovy-* installation/removals were made using apt-get. It MIGHT have been an issue with YAML dependency, which kept appearing during crashes.

edit flag offensive delete link more

Comments

You want to remove the pip version not install a new one. Otherwise you will run into the same problem in the future.

tfoote gravatar image tfoote  ( 2014-01-27 07:32:32 -0600 )edit

@tfoote, uninstalling rosdep using pip just simple didn't worked :) I've tried that before upgrading.

Kamiccolo gravatar image Kamiccolo  ( 2014-01-27 07:40:08 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2014-01-27 06:03:12 -0600

Seen: 556 times

Last updated: Feb 04 '14