Ask Your Question
3

Sound localization with Kinect and ROS?

asked 2011-12-08 14:36:00 -0600

BC5389 gravatar image

updated 2016-10-24 09:03:08 -0600

ngrennan gravatar image

I am doing a my senior project in school and want to do a robot that follows sound is it possible to access the Kinect's microphones for sound localization with ROS?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
3

answered 2012-03-06 18:21:43 -0600

tfoote gravatar image

You should probably check out the HARK project.

edit flag offensive delete link more
0

answered 2012-03-19 14:36:25 -0600

Hi, I also tried the Hark project, but the package installation seems not to be made for oneiric (11.10 Ubuntu, ROS electric), but for lucid only (10.4), this is the line from the HARK tutorial:

sudo sh -c 'echo "deb http://winnie.kuis.kyoto-u.ac.jp/HARK/harkrepos lucid non-free\ndeb-src http://winnie.kuis.kyoto-u.ac.jp/HARK/harkrepos lucid non-free" > /etc/apt/sources.list.d/hark.list'

Changing the string "lucid" to "oneiric" results in a page not found (404 error). Can I install lucid packages for oneiric?

I tried using the lucid repository, but when executing the following line:

sudo apt-get install harkfd hark-ros-electric hark-ros-turtlebot-stack-electric . Now I got the following error, maybe this is because the lucid-version does not fit:

===========

The following packages have unmet dependencies: hark-ros-electric : Depends: libboost-signals1.40.0 (>= 1.40.0-1) but it is not installable Depends: libboost-thread1.40.0 (>= 1.40.0-1) but it is not installable hark-ros-turtlebot-stack-electric : Depends: libboost-signals1.40.0 (>= 1.40.0-1) but it is not installable Depends: libboost-thread1.40.0 (>= 1.40.0-1) but it is not installable harkfd : Depends: libboost-thread1.40.0 (>= 1.40.0-1) but it is not installable Depends: libharkio1 but it is not going to be installed E: Unable to correct problems, you have held broken packages.

===========

My libboost-signals and libboost-thread is version 1.46, I reinstalled it, but the error remains. Any suggestions? Thanks!

edit flag offensive delete link more

Comments

You cannot generally install lucid packages on oneiric.

tfoote gravatar imagetfoote ( 2012-04-23 09:07:32 -0600 )edit

You can download the source code of HARK and try to compile them. http://winnie.kuis.kyoto-u.ac.jp/HARK/wiki.cgi?page=Softwares#p10

mzmttks gravatar imagemzmttks ( 2014-03-11 01:49:53 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-12-08 14:36:00 -0600

Seen: 1,675 times

Last updated: Mar 19 '12