Ask Your Question
1

Kinect content missing on the Turtlebot

asked 2011-11-23 13:31:28 -0600

Alaina gravatar image

updated 2016-10-24 08:59:30 -0600

ngrennan gravatar image

I'm coming back to Turtlebot after a couple of months on other things. Wow, things are looking great! It's really coming together.

I'm having a curious problem and I hope someone can provide some guidance. This started out when I started running through the gmapping tutorial. Teleoperation was working fine, but I wasn't seeing anything coming up in rviz. So I tried subscribing to the image topics, using image_view, etc. Still no video. So now I've backed up and am trying to resolve this problem.

After figuring out that the stuff in kinect.launch wasn't referenced in turtlebot.launch and is now brought up separately (I am lazy and created a custom launch file that includes kinect.launch), I got the openni_kinect topics to show up. The Kinect is powered on, it shows up in lsusb, etc., and the laser is merrily red. Here's my rostopic list:

/camera/depth/camera_info
/camera/depth/disparity
/camera/depth/image
/camera/depth/image/compressed
/camera/depth/image/compressed/parameter_descriptions
/camera/depth/image/compressed/parameter_updates
/camera/depth/image/theora
/camera/depth/image/theora/parameter_descriptions
/camera/depth/image/theora/parameter_updates
/camera/depth/image_raw
/camera/depth/image_raw/compressed
/camera/depth/image_raw/compressed/parameter_descriptions
/camera/depth/image_raw/compressed/parameter_updates
/camera/depth/image_raw/theora
/camera/depth/image_raw/theora/parameter_descriptions
/camera/depth/image_raw/theora/parameter_updates
/camera/depth/points
/camera/rgb/camera_info
/camera/rgb/image_color
/camera/rgb/image_color/compressed
/camera/rgb/image_color/compressed/parameter_descriptions
/camera/rgb/image_color/compressed/parameter_updates
/camera/rgb/image_color/theora
/camera/rgb/image_color/theora/parameter_descriptions
/camera/rgb/image_color/theora/parameter_updates
/camera/rgb/image_mono
/camera/rgb/image_mono/compressed
/camera/rgb/image_mono/compressed/parameter_descriptions
/camera/rgb/image_mono/compressed/parameter_updates
/camera/rgb/image_mono/theora
/camera/rgb/image_mono/theora/parameter_descriptions
/camera/rgb/image_mono/theora/parameter_updates
/camera/rgb/image_raw
/camera/rgb/image_raw/compressed
/camera/rgb/image_raw/compressed/parameter_descriptions
/camera/rgb/image_raw/compressed/parameter_updates
/camera/rgb/image_raw/theora
/camera/rgb/image_raw/theora/parameter_descriptions
/camera/rgb/image_raw/theora/parameter_updates
/camera/rgb/points
/cloud_throttled
/cmd_vel
/diagnostics
/diagnostics_agg
/imu/data
/imu/raw
/joint_states
/kinect_laser/parameter_descriptions
/kinect_laser/parameter_updates
/kinect_laser_narrow/parameter_descriptions
/kinect_laser_narrow/parameter_updates
/map
/map_metadata
/narrow_scan
/odom
/openni_camera/parameter_descriptions
/openni_camera/parameter_updates
/openni_manager/bond
/robot_pose_ekf/odom
/rosout
/rosout_agg
/scan
/slam_gmapping/entropy
/tf
/turtlebot/app_list
/turtlebot/application/app_status
/turtlebot_node/parameter_descriptions
/turtlebot_node/parameter_updates
/turtlebot_node/sensor_state

... except nothing seems to be actually publishing to the camera topics. For example, a "rostopic hz /camera/rgb/image_color" doesn't give me anything, but a rostopic hz /odom gives me the rate info I expect. None of the other /camera topics get anything, either; I get no response from /camera/depth/image,

Sooo, back to rviz. If I add a display in rviz (Camera, topic /camera/rgb/image_color), I get a Status: warning message that says "No CameraInfo received on [/camera/rgb/camera_info]. Topic may not exist. But it does exist (see above), it's just that nothing is happening on it. if I rostopic echo or rostopic hz on /camera/rgb/camera_info, I don't see anything.

I tried running the gmapping stuff, which launches the kinect stuff ... (more)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2011-11-23 18:30:04 -0600

Ben_S gravatar image

You might have a look at this answer by Patrick Mihelich to another similar kinect related question. I dont know if the new binaries are already out, but i doubt it. Maybe you could try to build the most recent version from source like suggested and give feedback to Patrick if it helped.

I was fighting with this issue for weeks with natty and electric and for me a clean reinstall and switch vom 32 to 64 bit helped a lot, but didnt solve the problem completely.

edit flag offensive delete link more

Comments

That's great, Ben. If I rosinstall/rosmake the latest, it works fine. Looks like we can expect a permanent fix soon.
Alaina gravatar imageAlaina ( 2011-11-24 00:32:24 -0600 )edit
0

answered 2011-11-24 00:40:16 -0600

Alaina gravatar image

Patrick's work, as linked in his answer above, fixed the problem.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-23 13:31:28 -0600

Seen: 487 times

Last updated: Nov 24 '11