Ask Your Question
0

Problem of running "rosrun turtlesim turtlesim_node"

asked 2014-01-21 17:14:34 -0500

mrq44106 gravatar image

updated 2016-04-20 16:48:19 -0500

130s gravatar image

Hey guys, I am new to ros and try to learn it by going through the beginner tutorial. However, when I tried typing the code "rosrun turtlesim turtlesim_node" provided in "Understandingnodes" part of the tutorial, the turtlesim window just flicked and then disappeared. I got the error message:

[ INFO] [1390367521.100598911]: Starting turtlesim with node name /turtlesim
[ INFO] [1390367521.107999703]: Spawning turtle [turtle1] at x=[5.544445], y=[5.544445], theta=[0.000000]
/opt/ros/hydro/lib/turtlesim/turtlesim_node: symbol lookup *****error: /opt/ros/hydro/lib/libroscpp.so: undefined symbol: _ZN3ros6HeaderC1Ev*****

I simply cannot do anything with the turtle since I can't see the window at all. Do you guys have any idea or suggestion? Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
6

answered 2014-01-21 21:02:20 -0500

Wolf gravatar image

updated 2014-01-21 21:10:50 -0500

Just a couple of minutes ago I also had some weird symbol lookup errors, too (After pulling some updates with the update manager).

sudo apt-get install -f

and

sudo apt-get autoremove

together with erasing build dirs and rebuilding in my workspace by (in the catkin_ws folder:)

rm -r devel
rm -r build
catkin_make

solved the issue....

edit flag offensive delete link more

Comments

The turtlesim window shows up after trying your instructions. Thanks a lot!

mrq44106 gravatar image mrq44106  ( 2014-01-22 02:32:52 -0500 )edit

i have done the same and I can not fix it. Any ideas? The problem is the same..

Alvaro Salcedo gravatar image Alvaro Salcedo  ( 2015-09-11 06:15:05 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-21 17:14:34 -0500

Seen: 4,859 times

Last updated: Apr 20 '16