Ask Your Question
0

turtlebot gmapping with electric.

asked 2011-11-20 20:45:31 -0500

apalomer gravatar image

Hi, I upgraded to electric and the gmapping is not workind. I think that the problem is that the base_footprint is not conected to the odometry. I can see it in the RVIZ if I cheeck the TF, in Frames, /base_footprint doesn't have a parent. Where can I find the code for this TF and change it?

Thanks.

edit retag flag offensive close merge delete

Comments

Can you describe the phenomenon more?
130s gravatar image 130s  ( 2011-11-21 09:27:45 -0500 )edit
Well, it's juts that the transform from the robot to the odometry is not there, and I want to add this part, but I don't know where the transform code is.
apalomer gravatar image apalomer  ( 2011-11-21 20:52:19 -0500 )edit
can you please provide more information what version of the turtlebot software are you running? and can you run rosrun tf view_frames . this will create a pdf of your tf tree, can you please attach the pdf to this page so I can look at it.
mmwise gravatar image mmwise  ( 2011-11-26 10:29:49 -0500 )edit
I haven't changed anything but the position of the kinect on the turtlebot and now it works.... I really don't understand!
apalomer gravatar image apalomer  ( 2011-11-27 21:14:48 -0500 )edit
I've had the same issue. However, I compiled the Electric source. As I was doing the teleop around the room, I was getting error messages that kept saying that base_footprint wasn't getting mapped to the odom.
osuairt gravatar image osuairt  ( 2011-12-06 17:28:12 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2011-12-23 06:57:23 -0500

Nick Armstrong-Crews gravatar image

You need to run robot_pose_ekf to get the /odom frame in your tf tree. From what I can tell, in diamondback it was run whenever the robot was "brought up" ... but in electric, this seems to have been changed.

Example launch file:

<node pkg="robot_pose_ekf" type="robot_pose_ekf" name="robot_pose_ekf">
  <param name="freq" value="10.0"/>
  <param name="sensor_timeout" value="1.0"/>
  <param name="publish_tf" value="true"/>
  <param name="odom_used" value="true"/>
  <param name="imu_used" value="true"/>
  <param name="vo_used" value="false"/>
  <param name="output_frame" value="odom"/>
  <remap from="imu_data" to="imu/data"/>
</node>
edit flag offensive delete link more

Comments

oops, forgot <launch> </launch> enclosing tags
Nick Armstrong-Crews gravatar image Nick Armstrong-Crews  ( 2011-12-23 06:57:59 -0500 )edit
In more recent releases, the ekf filter is launched with the robot minimal.launch so that odometry is always available.
fergs gravatar image fergs  ( 2011-12-24 01:00:38 -0500 )edit
0

answered 2011-11-21 02:02:44 -0500

apalomer gravatar image

Hi again, I've cheeked the interactive markers and they don't work either. The problem that I get is that there's no connection between the base_footprint and the odom, the same problem as in the gmapping. How can I solve it?

Thanks

edit flag offensive delete link more

Comments

Hey, I had the same issue. I downloaded the source, the interactive markers were then working.
osuairt gravatar image osuairt  ( 2011-12-06 17:26:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-20 20:45:31 -0500

Seen: 411 times

Last updated: Dec 23 '11