getting velodyne poll() timeout warning, i can see data but velodyne node can't [closed]

asked 2014-01-20 10:42:18 -0600

Leeom gravatar image

updated 2014-01-28 17:19:06 -0600

ngrennan gravatar image

I have a HDL-32E sensor and got it working fine on my other PCs., thanks to the velodyne node by Joq.

But on my laptop, I am getting "velodyne poll() timeout" when i try to do 'rosrun velodyne_driver velodyne_node' I am aware of other people getting this error and having them resolved with correct network settings, but none of the solutions i found online worked for me. Another funny thing is I can record the sensor data using vdump, and play it out and even get the pointclouds with no problem, but it just wouldn't work in live setting.

I am using ros hydro on ubuntu raring over chroot (from a chromebook).
I suspect that it might be the chroot that is preventing me from accessing eth0 without root permissions. But them again, I also tried but had no luck even with sudo -s. I was getting traffic over eth0 just fine (checked with bmon), and I noticed I need root permission when I tried to look at the packets using wireshark. This led me to suspect that something needed root permission, but then I was able to use vdump.

I hope this makes sense. This has been driving me nuts! Please help!

Thanks,

slym

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2016-08-14 01:57:50.976105

Comments

I have never tried this driver in a chroot or on a chromebook. On an Ubuntu system you should not need root permission to run it, it probably will not work as root. The vdump script uses sudo internally, because tcpdump requires it, but the Velodyne port itself is user-readable.

joq gravatar imagejoq ( 2014-01-20 13:48:32 -0600 )edit