Ask Your Question
8

Unmet dependencies in ros-electric-desktop-full installation

asked 2011-11-11 13:52:13 -0500

esha_umn gravatar image

updated 2011-11-11 20:27:21 -0500

AHornung gravatar image

I come up with the following error while installing ros-electric-desktop-full:

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: ros-electric-desktop-full: Depends: ros-electric-vision-opencv (= 1.6.8-s1321009367~lucid) but it is not going to be installed Depends: ros-electric-image-pipeline (= 1.6.3-s1321009993~lucid) but it is not going to be installed Depends: ros-electric-image-transport-plugins (= 1.4.2-s1321009887~lucid) but it is not going to be installed E: Broken packages

So I went ahead and tried to install ros-electric-vision-opencv on its own using "sudo apt-get install ros-electric-vision-opencv", but had the following error message:

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: ros-electric-vision-opencv: Depends: libopencv2.3-dev (= 2.3.1+svn6514+branch23-8~lucid) but 2.3.1+svn6514+branch23-6~lucid is to be installed E: Broken packages

Is there a problem with the dependencies for libopencv2.3-dev?

Thank you!

Edit1: Looking into the problem further, I noticed that http://packages.ros.org/ros/ubuntu/lists/ros-lucid-electric_lucid_main_i386_Packages (updated today) uses 2.3.1+svn6514+branch23-8~lucid for libopencv2.3-dev. However,http://packages.ros.org/ros/ubuntu/dists/lucid/main/binary-i386/Packages uses 2.3.1+svn6514+branch23-6~lucid. I think this is causing the problem. Should this be reported as a bug?

edit retag flag offensive close merge delete

Comments

I found this to be the case, as well: The following packages have unmet dependencies:ros-electric-eigen : Depends: libeigen3-dev (= 3.0.1-1+ros4~natty) but 3.0.2-3+natty1 is to be installed
Daniel Canelhas gravatar imageDaniel Canelhas ( 2011-11-11 17:26:02 -0500 )edit
The problem with dependencies has been sorted out. I managed to install electric-desktop-full successfully today.
esha_umn gravatar imageesha_umn ( 2011-11-14 08:03:28 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
1

answered 2011-11-12 23:21:19 -0500

demmeln gravatar image

I had the same problem as the OP (lucid and oneiric). The problem seems to (now) be fixed for me by switching from Freiburg mirror to the main mirror. So it might be fixed upstream but changes need a while to settle down.

edit flag offensive delete link more
0

answered 2011-11-11 20:29:49 -0500

AHornung gravatar image

Could this be related to this question?

Otherwise, it could just be the case the the repostitory is in the process of being updated and the dependencies didn't propagate through completely yet.

edit flag offensive delete link more

Comments

I had a working installation and accepted an update some days ago, which basically seems to have broken it.
Daniel Canelhas gravatar imageDaniel Canelhas ( 2011-11-12 10:41:27 -0500 )edit
0

answered 2011-11-13 08:31:13 -0500

MichaelHsu170 gravatar image

How to switch from Freiburg mirror to the main mirror?

I followed instructions in the page, but always Unmet dependencies from the night before yesterday. Installations before that night always succeeded.

edit flag offensive delete link more

Comments

I manually edited /etc/apt/sources.list.d/ros-latest.list to only contain the following line: "deb http://packages.ros.org/ros/ubuntu oneiric main". Make sure to substitue oneiric for whatever dist u r using. Don't forget to call "sudo apt-get update" afterwards, before trying to install/upgrade.
demmeln gravatar imagedemmeln ( 2011-11-13 12:36:57 -0500 )edit
The content of my /etc/apt/sources.list.d/ros-latest.list is exact the "deb http://packages.ros.org/ros/ubuntu oneiric main", but still Unmet dependencies.
MichaelHsu170 gravatar imageMichaelHsu170 ( 2011-11-13 13:00:32 -0500 )edit
So I assume you have oreinic installed and did apt-get update. You could try installing the offending packages directly. For me I think "apt-get install ros-electric-vision-opencv" help. If that shows you a missing dependency, try installing that dependency directly and so on.
demmeln gravatar imagedemmeln ( 2011-11-13 13:30:32 -0500 )edit
Yup, I sudo apt-get installed libopencv2.3-dev, though. Still "Depends: libopencv2.3-dev (= 2.3.1+svn6514+branch23-7~oneiric) but 2.3.1+svn6514+branch23-8~oneiric is to be installed". The same as http://answers.ros.org/question/2887/libopencv23-dev-conflict
MichaelHsu170 gravatar imageMichaelHsu170 ( 2011-11-13 14:34:27 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-11 13:52:13 -0500

Seen: 1,344 times

Last updated: Nov 13 '11