Ask Your Question
1

connect two separate computers using bluetooth

asked 2011-11-09 12:51:27 -0500

dougnets22 gravatar image

updated 2011-11-10 02:46:06 -0500

joq gravatar image

So, I have been fighting with this for the past 2 days now. I have two separate computers, each running Ubuntu of course, and each has its own bluetooth dongle (same make and model). I can get each of the computers to bond to one another, but when I try to telnet via Putty or any other means I get the following error:

Connection Refused

(#via Putty)

or

Can't connect RFCOMM socket: Connection refused

(#via rfcomm in the terminal)

To give you a bit more info., I have also tried to connect each computer using ssh over WLAN. However, I get the following error:

ssh: connect to host HOSTNAME port 22: Connection refused

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2011-11-10 05:12:45 -0500

dougnets22 gravatar image

Alright, I figured out how to manually get the rfcomm0 by doing the following:

cd /dev

sudo mknod --mode 600 /dev/rfcomm0 c 216 0

Then I uncommented the following lines in my /etc/bluetooth/rfcomm.conf file:

rfcomm0 {

      bind yes; #set no to yes if it is not already set

      device <bdaddr>; #where bdaddr is the address of the bluetooth with which you are trying to bind

      channel 1; #I think any channel will do

      comment "Add whatever you want here";

}

I'm not sure as to whether or not I needed to do the first portion once I uncommented the rfcomm0 stuff, but it worked nonetheless. Once I had that bit working, I tried your command Bemfica along with a sudo rfcomm -a to check the connection. Finally, I transferred a file by typing: bluetooth-sendto <filename>. So, it looks like I'm at least moving in the right direction. I'll be back with more questions/answers.

edit flag offensive delete link more

Comments

you should edit your question putting the resolution you found instead of post an answer
Bemfica gravatar image Bemfica  ( 2011-11-11 01:44:30 -0500 )edit
0

answered 2011-11-10 04:10:35 -0500

dougnets22 gravatar image

Unfortunately, I have yet to see a rfcomm0 in the dev directory

edit flag offensive delete link more
0

answered 2011-11-09 21:40:18 -0500

Bemfica gravatar image

after connecting to the Bluetooth adapter, try to run the command
sudo rfcomm bind /dev/rfcomm0

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-11-09 12:51:27 -0500

Seen: 2,101 times

Last updated: Nov 10 '11