Ask Your Question
0

rosmake { rosjava, rosjava_core } fails

asked 2011-10-19 06:38:50 -0500

130s gravatar image

updated 2011-10-19 06:39:52 -0500

Hello all, both rosmake rosjava and rosmake rosjava_core fail with the following error (on Env-1):

  rosrun rosjava_bootstrap make.py apache_commons_util
  Traceback (most recent call last):
    File "/home/rosman/ros_ws/rosjava/rosjava_bootstrap/src/main/python/rosjava_bootstrap/make.py", line 108, in <module>
      main(sys.argv)
    File "/home/rosman/ros_ws/rosjava/rosjava_bootstrap/src/main/python/rosjava_bootstrap/make.py", line 100, in main
      build(rospack, package)
    File "/home/rosman/ros_ws/rosjava/rosjava_bootstrap/src/main/python/rosjava_bootstrap/make.py", line 59, in build
      maven_depmap = maven.get_maven_dependencies(package, 'dependencies.xml')
    File "/home/rosman/ros_ws/rosjava/rosjava_bootstrap/src/main/python/rosjava_bootstrap/maven.py", line 216, in get_maven_dependencies
      subprocess.check_call(command)
    File "/usr/lib/python2.7/subprocess.py", line 499, in check_call
      retcode = call(*popenargs, **kwargs)
    File "/usr/lib/python2.7/subprocess.py", line 486, in call
      return Popen(*popenargs, **kwargs).wait()
    File "/usr/lib/python2.7/subprocess.py", line 672, in __init__
      errread, errwrite)
    File "/usr/lib/python2.7/subprocess.py", line 1213, in _execute_child
      raise child_exception
  OSError: [Errno 2] No such file or directory

Error on Env-2 is similar.

I checked files/folders (rosjava_bootstrap make.py apache_commons_util) that are called by rosrun in the error are all found.

Also I'm confused if I should download and use rosjava or rosjava_core. This page says I should use

hg clone https://code.google.com/p/rosjava/

but this page says

hg clone https://rosjava.googlecode.com/hg/ rosjava_core

Env-1: Ubuntu 11.04, electric, python2.7

Env-2: Ubuntu 10.10, electric, python2.6

Thanks.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-10-19 06:54:39 -0500

kwc gravatar image

The error that is being raised would usually be caused if you don't have ant installed. Ant is a build tool for java.

As for the hg clone instructions, Google Code auto-generates checkout documentation. The correct instructions are:

hg clone https://rosjava.googlecode.com/hg/ rosjava_core

edit flag offensive delete link more

Comments

Thanks, those solved my problem and now rosmake completes w/o errors (after ant, I still had to install javac via openjdk-6-jdk though).
130s gravatar image 130s  ( 2011-10-19 07:12:37 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-10-19 06:38:50 -0500

Seen: 334 times

Last updated: Oct 19 '11