Ask Your Question
0

rviz segmentation fault on launch in electric

asked 2011-10-16 21:59:45 -0500

osuairt gravatar image

updated 2011-10-16 22:01:31 -0500

Hi,

I am running electric with 10.04, I get the following:

xxxxx@ubuntu:~$ rosrun rviz rviz

rviz revision number 1.6.4ng with size 1 x 1

ogre_tools revision number 1.6.2

compiled against OGRE version 1.7.3 (Cthugha)

Loading general config from [/home/xxxxx/.rviz/config]

Loading display config from [/home/xxxxx/.rviz/display_config]

RTT Preferred Mode is PBuffer.

Texture for pass 0: creating with size 1 x 1

Segmentation fault

I have done some searching here on answers without anything working for me. The suggestion is that you should just remove .rviz/display_config, however one doesn't exist in the first place. So guys and gals, what should I do? I would rather not install diamondback. There was suggestions that that still works. This should work under electric.

Appreciate any help.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2011-10-17 02:09:09 -0500

Maybe this post will help you RViz in ROS electric

edit flag offensive delete link more

Comments

Hi, thanks. I came across this post before, and it doesn't.
osuairt gravatar image osuairt  ( 2011-10-19 22:58:27 -0500 )edit
3

answered 2011-10-18 03:26:48 -0500

akargol gravatar image

I had a very similar problem at one point. Deleting the entire .rviz directory in my home directory (not just .rviz/display_config) solved my problem. I also had the same problem running rviz in a VM, but in that case it was related to how the VM allowed access to the video card, and so couldn't be solved.

edit flag offensive delete link more

Comments

I tried deleting the entire .rviz and I still get the same segfault. I'll look more into whether it is a VM issue or not, thanks.
osuairt gravatar image osuairt  ( 2011-10-19 22:59:28 -0500 )edit
I went ahead and installed diamondback to see if it will work, and it does. For my purposes I will stick with diamondback, but this is a bit of a pain in the ass, because it is an on going problem it seems.
osuairt gravatar image osuairt  ( 2011-10-19 23:13:35 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-10-16 21:59:45 -0500

Seen: 1,288 times

Last updated: Oct 18 '11