Ask Your Question
0

Rviz doesn't visualize any meshes

asked 2014-01-06 23:51:45 -0500

ercarrion43 gravatar image

Hi, recently I installed hydro in a computer with fuerte while mantaining this latter version. I had several problems, one solved here:

"answers.ros.org/question/44996/cannot-run-roscore-due-to-error-in-rosversion/"

and another with rviz showing this message:

The latter was solved after actualizing to rviz 1.10.10, but now it doesn't display any meshes: not collada meshes sent through a marker not even a point cloud when is displayed in style "cubes" (though it properly represent the cloud in any of the other sytles).

The packages and meshes I am using works fine in other computers where I also installed hydro jointly with a fuerte version (though I never got this warn from rviz previously).

I don't know what more to do, I uninstalled fuerte and reinstalled hydro with no improvements. Any one has idea about where this fail may come from? Thanks in advance!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-01-07 07:00:55 -0500

Athoesen gravatar image

You might need to make sure you source Hydro. Go to your terminal, use the command cd && nano .bashrc to enter the file and add the line source /opt/ros/hydro/setup.bash at the end. Hit ctrl+X to exit and hit y to save changes. See if this helps at all.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-01-06 23:51:45 -0500

Seen: 122 times

Last updated: Jan 07 '14