Ask Your Question
1

tf on electric + maverick + Beagleboard

asked 2011-10-07 20:36:39 -0500

gertr gravatar image

updated 2014-01-28 17:10:32 -0500

ngrennan gravatar image

Hi all

I am trying to get my custom robot to run from a beagleboard. I have Ubuntu 10.10 running on it and installed the ROS electric base variant. I have tried to install the full variant, but I get the following message:

E: Unable to locate package ros-electric-desktop-full

I require the tf package for my robot and have tried to install it using the following command in terminal:

sudo apt-get install ros-electric-tf

which could also not be found...

I have since installed everything that I could using this command:

$ sudo apt-get install ros-electric-*

But I still dont have the tf package...

Can anybody give me instructions on how to get the tf package on my beagleboard...

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2011-10-08 04:29:35 -0500

Eric Perko gravatar image

Since you are on the Beagleboard, you will need Armel packages, not the standard i386 or x86-64 packages. While Willow Garage has started to build Armel .debs, most ROS stacks are not currently building for Armel. See the electric build status for details. You want the maverick-armel column and anything not in white will not have a .deb in the repository. Note that as of right now, geometry is not successfully built for armel.

You can try to install the geometry stack from source (using either rosinstall or just checking the stack out onto your ROS_PACKAGE_PATH), but since it's not building as a .deb, I don't expect it to build without patching on your Beagleboard. You may be able to build just tf (rosmake --rosdep-install tf) after checking out the geometry stack and, if tf and it's dependencies don't fail, you'll be able to get up and running.

edit flag offensive delete link more
1

answered 2011-10-07 23:25:40 -0500

AHornung gravatar image

The tf package is in the geometry stack. Thus, it is installed if you have the debian package ros-electric-geometry installed. If that can't be installed then maybe there is no ROS apt-repository in your sources.list?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-10-07 20:36:39 -0500

Seen: 669 times

Last updated: Oct 08 '11