Problem with libreadline in MTTD [closed]

asked 2011-10-03 03:31:09 -0600

Jmmy86 gravatar image

updated 2014-01-28 17:10:28 -0600

ngrennan gravatar image

Hello,

I am trying to get MTTD working, but I am already stuck at the tutorial example (http://www.ros.org/wiki/twoLevelMTTDExamples/Tutorials/Running%20twoLevelMTTDExamples%20-%20Experiment%201)

I used:

svn co http://svn.mech.kuleuven.be/repos/orocos/trunk/kul-ros-pkg/stacks/twoLevelMTTD_stack

For the first step:

rosmake twoLevelMTTDExamples

I needed more svn co 's for ocl_1.10, kdl_1.0, bfl_dataAssociationBranch and rtt_1.10

After that I got the following output:

[ rosmake ] Packages requested are: ['twoLevelMTTDExamples']                                         
[ rosmake ] Logging to directory/home/s088964/.ros/rosmake/rosmake_output-20111003-170259            
[ rosmake ] Expanded args ['twoLevelMTTDExamples'] to:
['twoLevelMTTDExamples']                      
[ rosmake ] Checking rosdeps compliance for packages twoLevelMTTDExamples.  This may take a few seconds.
Failed to find rosdep libreadline5-dev for package twoLevelMTTDExamples on OS:ubuntu version:lucid
Failed to find rosdep omniorb for package twoLevelMTTDExamples on OS:ubuntu version:lucid
WARNING: Rosdeps [u'libreadline5-dev', u'omniorb'] could not be resolved
Failed to find rosdep libreadline5-dev for package twoLevelMTTDExamples on OS:ubuntu version:lucid
Failed to find rosdep omniorb for package twoLevelMTTDExamples on OS:ubuntu version:lucid
[ rosmake ] rosdep check failed to find system dependencies: libreadline5-dev, omniorb               
[rosmake-0] Starting >>> rtt_1.10 [ make ]                                                           
[rosmake-1] Starting >>> eigen [ make ]                                                              
[rosmake-1] Finished <<< eigen ROS_NOBUILD in package eigen                                          
[rosmake-1] Starting >>> srl_people_tracker_0.2 [ make ]                                             
[ rosmake ] All 10 linestt_1.10: 0.0 sec ] [ srl_people_tracker_0.2: 0.... [ 2 Active 1/15 Complete ]
{-------------------------------------------------------------------------------
  mkdir -p build
  `rospack find rosbuild`/bin/download_checkmd5.py http://othello.informatik.uni-freiburg.de/~luber/html/people_tracker/code/srl-people-tracker-0.2.tgz build/srl-people-tracker-0.2.tgz
  touch -c build/srl-people-tracker-0.2.tgz
  rm -rf build/srl_source build/srl-people-tracker-0.2
  cd build; tar xzf ../build/srl-people-tracker-0.2.tgz

  gzip: stdin: not in gzip format
  tar: Child returned status 1
  tar: Exiting with failure status due to previous errors
-------------------------------------------------------------------------------}
[ rosmake ] Output from build of package srl_people_tracker_0.2 written to:
[ rosmake ]    /home/s088964/.ros/rosmake/rosmake_output-20111003-170259/srl_people_tracker_0.2/build_output.log
[rosmake-1] Finished <<< srl_people_tracker_0.2 [FAIL] [ 0.07 seconds ]                              
[ rosmake ] Halting due to failure in package srl_people_tracker_0.2. 
[ rosmake ] Waiting for other threads to complete.
[rosmake-0] Finished <<< rtt_1.10 [SKIP] No rule to make target None                                 
[ rosmake ] Results:                                                                                 
[ rosmake ] Built 3 packages with 1 failures.                                                        
[ rosmake ] Summary output to directory                                                              
[ rosmake ] /home/s088964/.ros/rosmake/rosmake_output-20111003-170259                                
[ rosmake ] WARNING: Rosdep did not detect the following system dependencies as installed: libreadline5-dev, omniorb Consider using --rosdep-install option or `rosdep install twoLevelMTTDExamples`

I cant fix this part:

Failed to find rosdep libreadline5-dev for package twoLevelMTTDExamples on OS:ubuntu version:lucid

I found libreadline5-dev in ubuntu software centre and installed it but that didn't work. I also tried to find it after installing:

cd /usr/lib
ls *libread*

That gave:

libreadline.a  libreadline.so

To find the file causing this problem I used:

rosdep what_needs libreadline5-dev

That gave me:

ocl_1.10

I found the manifest files which contained:

  <rosdep name="libreadline5-dev"/>

But I don't know what to do with it, change it to libreadline.so ? That didn't work.

Is there anyone who knows how I can make this example work?

The same hold for the omniorb part, but that one is needed for ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2013-02-03 07:35:48