Ask Your Question
1

Openni drivers installation errors

asked 2011-09-27 08:15:31 -0500

karthik gravatar image

I followed http://www.ros.org/wiki/openni_kinect wiki page to install the openni drivers and encountered following errors when i tried to resolve them. After downloading the drivers from the mentioned link (mercurial: hg clone https://kforge.ros.org/openni/drivers) I tried to make debian (I am on maverick and using diamondpack version of ROS).

    dpkg-deb: building package `openni-dev' in `ros-openni-dev-1.3.2.1~maverick_i3863.deb'.
cd ps_engine && make
make[1]: Entering directory `/home/aravindhan/drivers_27_sep_2011/ps_engine'
make[1]: *** No rule to make target `fix-mac-arch', needed by `patched'.  Stop.
make[1]: Leaving directory `/home/aravindhan/drivers_27_sep_2011/ps_engine'
make: *** [ps_engine_lib] Error 2

I realised the problem with Makefile in the ps-engine and checked the contents and found fix-mac-arch file missing in the folder. I am not sure about this patching concept so i searched for the same in the drivers folder and found it in /drivers/openni folder. Just in order to check if things might work, i copied the file into the /drivers/ps-engine folder and tried to make the debian and got the below error.

make[1]: Entering directory `/home/aravindhan/drivers_27_sep_2011/ps_engine'
cd build/ps_engine && git reset --hard
HEAD is now at 342e334 Added missing makefiles.
patch -d build/ps_engine -p1 < willow.patch &&   patch -d build/ps_engine -p1 < disable_sse &&   patch -d build/ps_engine -p1 < disable_LogWriteToFile &&   patch -d build/ps_engine -p1 < fix-includes &&   patch -d build/ps_engine -p1 < fix-mac-arch &&  echo patched
patching file Platform/Linux-x86/Build/EngineLibMakefile
patching file Platform/Linux-x86/Build/Utils/EngineUtilMakefile
patching file Source/XnDeviceSensorV2/Registration.cpp
patching file Source/XnDeviceSensorV2/XnDataProcessor.h
patching file Source/XnDeviceSensorV2/XnDeviceSensorIO.cpp
patching file Source/XnDeviceSensorV2/XnDeviceSensorProtocol.h
patching file Source/XnDeviceSensorV2/XnFirmwareStreams.cpp
patching file Source/XnDeviceSensorV2/XnHostProtocol.h
patching file Source/XnDeviceSensorV2/XnSensorDepthStream.cpp
patching file Source/XnDeviceSensorV2/XnSensorDepthStream.h
patching file Source/XnDeviceSensorV2/XnSensorFirmwareParams.cpp
patching file Source/XnDeviceSensorV2/XnSensorImageStream.cpp
patching file Source/XnDeviceSensorV2/XnSensorImageStream.h
patching file Source/XnDeviceSensorV2/XnSensorIRStream.cpp
patching file Platform/Linux-x86/Build/Common/Platform.x86
patching file Data/GlobalDefaults.ini
patching file Platform/Linux-x86/Build/EngineLibMakefile
patching file Platform/Linux-x86/Build/Utils/EngineUtilMakefile
patching file Platform/Linux-x86/Build/Platform.x86
Hunk #1 FAILED at 6.
1 out of 1 hunk FAILED -- saving rejects to file Platform/Linux-x86/Build/Platform.x86.rej
make[1]: *** [patched] Error 1
make[1]: Leaving directory `/home/aravindhan/drivers_27_sep_2011/ps_engine'
make: *** [ps_engine_lib] Error 2

I am pretty sure its the fix-mac-arch file that is missing in ps-engine and patching problem is due to the wrong path in the same file. Did someone else face the same issue? Pls let me know if any archives are available for the same.

Thanks in advance, Karthik

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-09-30 05:04:51 -0500

Juan Saavedra gravatar image

I was having the same trouble on Fedora 15. It seems to me that the problem was introduced here, 3 days ago.

https://kforge.ros.org/openni/drivers/rev/b5dc08c27676

I actually removed the dependence, since from the description of the change, it is a patch for macs.

edit flag offensive delete link more

Comments

DId you just remove the fix-mac-arch from the Makefile?
karthik gravatar image karthik  ( 2011-10-06 05:17:41 -0500 )edit
Thanks Juan, It worked
karthik gravatar image karthik  ( 2011-10-06 06:10:36 -0500 )edit
But when i launch the openni_node.launch file as mentioned in wiki page, I am getting the status as below. "[ INFO] [1317931305.580038907]: [/openni_node1] No devices connected.... waiting for devices to be connected" .
karthik gravatar image karthik  ( 2011-10-06 08:03:14 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-09-27 08:15:31 -0500

Seen: 995 times

Last updated: Sep 30 '11