Ask Your Question
1

openni "creating depth generator failed"

asked 2011-07-11 08:14:06 -0500

monkey90 gravatar image

updated 2016-10-24 08:59:48 -0500

ngrennan gravatar image

Hello,

I just installed the diamondback base and openni_kinect package. Then, if I do

rosmake openni_camera everything was compiled successfully. Then, if I do roslaunch openni_camera openni_node.launch, it says

1 [ INFO] [1310405330.895790349]: [/openni_node1] 1. device on bus 002:06 is a Xbox NUI Camera (2ae) from Microsoft (45e) with serial id 'B00363708464051B' [ INFO] [1310405330.900782094]: [/openni_node1] searching for device with index = 1 [ INFO] [1310405334.914925388]: [/openni_node1] No matching device found.... waiting for devices. Reason: openni_wrapper::OpenNIDevice::OpenNIDevice(xn::Context&, const xn::NodeInfo&, const xn::NodeInfo&, const xn::NodeInfo&) @ /tmp/buildd/ros-diamondback-openni-kinect-0.2.1/debian/ros-diamondback-ope nni-kinect/opt/ros/diamondback/stacks/openni_kinect/openni_camera/src/ope nni_device.cpp @ 59 : creating depth generator failed. Reason: Got a timeout while waiting for a network command to complete!

like above.

I don't know how to solve this problem,

Can anybody help me with installing openni_kinect and what my problem is???

Thank you

edit retag flag offensive close merge delete

Comments

replug the device and then post the output of "dmesg" and "lsusb".
dornhege gravatar image dornhege  ( 2011-07-11 11:36:46 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-09-02 11:53:21 -0500

kwc gravatar image

no activity > 1 month, closing

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-07-11 08:14:06 -0500

Seen: 1,054 times

Last updated: Sep 02 '11