ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Openni kinect error make

asked 2011-09-23 08:50:17 -0500

Rikki gravatar image

updated 2011-09-23 09:18:47 -0500

tfoote gravatar image

Hi!! I'm trying to install the drivers's openni kinect in Ubuntu with ROS electric.

I installed ROS following "the ROS installation instrucion" and I did the first 9 tutorials, but when i tried to install the openni kinect following , the comand "make" fail.

That's the error message in the terminal:

miles@nono:~/drivers$ make
cd openni && make
make[1]: se ingresa al directorio «/home/miles/drivers/openni»
git clone build/openni
make[1]: git: No se encontró el programa
make[1]: *** [build/openni] Error 127
make[1]: se sale del directorio «/home/miles/drivers/openni»
make: *** [openni_lib] Error 2 me :(

edit retag flag offensive close merge delete


Please provide more information on what you have installed and how you did so, otherwise it's very hard to help you.
tfoote gravatar image tfoote  ( 2011-09-23 09:17:48 -0500 )edit
I have installed ros-electric-desktop-full. And for openin kinect, I only installed ros-electric-openni-kinect and rosinstall.
Rikki gravatar image Rikki  ( 2011-09-23 10:09:16 -0500 )edit

2 Answers

Sort by » oldest newest most voted

answered 2011-09-26 01:43:17 -0500

John Hoare gravatar image

I'm pretty sure that the error you're experiencing is because you do not have "git" installed.

If you're on ubuntu:

sudo apt-get install git

edit flag offensive delete link more

answered 2011-09-23 09:18:08 -0500

tfoote gravatar image

If you are using electric on Ubuntu I suggest that you use the debian based installation, listed at the top of the linked page, which is already compiled. If you're already using that you don't need to compile.

edit flag offensive delete link more


If I do the steps to "debian user" does not work either -> "$ make debian" produces the same error
Rikki gravatar image Rikki  ( 2011-09-23 10:02:27 -0500 )edit
but... you say i don´t need to complie? I don´t need to do "make"?
Rikki gravatar image Rikki  ( 2011-09-23 10:03:14 -0500 )edit
yes, the packages which come from apt have already had "make" called on them. calling "make" compiles the source code into binary machine code which can be executed. The error you're getting is just the first of many as the packages are also read only too.
tfoote gravatar image tfoote  ( 2011-09-26 07:18:55 -0500 )edit

Question Tools


Asked: 2011-09-23 08:50:17 -0500

Seen: 536 times

Last updated: Sep 26 '11