ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question
1

Installing pyqwt on Mavericks

asked 2013-12-23 14:57:58 -0600

fergs gravatar image

updated 2013-12-25 05:53:15 -0600

I've noticed several threads where people have claimed to have built ROS on OSX Mavericks, I'm currently unable to install pyqwt via homebrew, basically hitting this same error that has been reported but not solved: https://github.com/Homebrew/homebrew/issues/25224

I've tried reinstalling both qt and sip to no avail.

Any helpful hints?

edit retag flag offensive close merge delete

Comments

Are you using default Python?

Artem gravatar image Artem  ( 2013-12-24 17:07:37 -0600 )edit

Yes, using default Python.

fergs gravatar image fergs  ( 2013-12-25 05:32:52 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-12-24 20:26:36 -0600

jensenb gravatar image

The current release version of PyQt (4.10.3) has some issues with libc++/clang build settings necessary for Mavericks. Basically PyQt incorrectly parses the QMake build settings that were used to build Qt, resulting in incorrect build flags being generated for PyQt interoperable projects. There is a fix proposed for homebrew here: https://github.com/Homebrew/homebrew/pull/25225 and for PyQt here: http://www.riverbankcomputing.com/pipermail/pyqt/2013-December/033537.html

brew install <a href="https://raw.github.com/jensenb/homebrew/76e8bf65dccdeeb785ca2f296ac2458460ba2fde/Library/Formula/pyqt.rb">https://raw.github.com/jensenb/homebrew/76e8bf65dccdeeb785ca2f296ac2458460ba2fde/Library/Formula/pyqt.rb</a>
edit flag offensive delete link more

Comments

Thanks -- that works for me.

fergs gravatar image fergs  ( 2013-12-25 07:45:27 -0600 )edit

Question Tools

1 follower

Stats

Asked: 2013-12-23 14:57:58 -0600

Seen: 552 times

Last updated: Dec 24 '13