OpenRave installation fails under Electric + Ubuntu 10.04 [closed]

asked 2011-09-18 15:32:16 -0600

Pi Robot gravatar image

updated 2011-09-19 02:19:23 -0600

EDIT: False alarm. I had an older version of jsk_common in my ROS_PACKAGE_PATH that was causing the error. Once I removed it, rosmake was able to continue. Feel free to delete this post if desired.


Hello,

I have jsk-ros-pkg rev 2172 and the latest debians for ROS Electric under Ubuntu 10.04. When I run "rosmake --rosdep-install" in the openrave_planning directory, it fails on two dependencies: python-meminfo-total and python-paramiko. I have python-paramiko 1.7.6-2 and python-meminfo-total 0.4.7.

Here is the full output from rosmake:

$ rosmake --rosdep-install
[ rosmake ] No package specified.  Building stack ['openrave_planning']            
[ rosmake ] Packages requested are: ['openrave_planning']                          
[ rosmake ] Logging to directory/home/patrick/.ros/rosmake/rosmake_output-20110918-202300
[ rosmake ] Expanded args ['openrave_planning'] to:
['openrave_actionlib', 'orrosplanning', 'session_tutorials', 'openrave_sensors', 'openrave_robot_filter', 'roscpp_sessions', 'openrave', 'openrave_calibration', 'openrave_robot_control', 'collada_robots', 'soqt', 'openraveros', 'openrave_database']
[ rosmake ] Generating Install Script using rosdep then executing. This may take a minute, you will be prompted for permissions. . .
Failed to find rosdep python-meminfo-total for package openrave_database on OS:ubuntu version:lucid
Failed to find rosdep python-paramiko for package openrave_database on OS:ubuntu version:lucid
Executing script below with cwd=/tmp
{{{
#!/bin/bash
if [ ! -f /etc/apt/sources.list.d/openrave-release*.list ] ; then
  echo "deb http://ppa.launchpad.net/openrave/release/ubuntu `lsb_release -cs` main" |  sudo tee /etc/apt/sources.list.d/openrave-release.list
  sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 58E6B835EDC85D09
  sudo apt-get -y update
fi
sudo apt-get -y --force-yes install libcollada15dom-dev

}}}

Reading package lists... Done
Building dependency tree       
Reading state information... Done
libcollada15dom-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 30 not upgraded.
Executing script below with cwd=/tmp
{{{
#!/bin/bash
if [ ! -f /etc/apt/sources.list.d/openrave-release*.list ] ; then
  echo "deb http://ppa.launchpad.net/openrave/release/ubuntu `lsb_release -cs` main" |  sudo tee /etc/apt/sources.list.d/openrave-release.list
  sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 58E6B835EDC85D09
  sudo apt-get -y update
fi
sudo apt-get -y --force-yes install assimp-dev

}}}

Reading package lists... Done
Building dependency tree       
Reading state information... Done
assimp-dev is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 30 not upgraded.
[ rosmake ] rosdep install failed: Rosdep install failed
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2012-06-09 10:37:05