Ask Your Question
13

Anyone using the new XBOX One Kinect?

asked 2013-12-10 08:53:32 -0600

TFinleyosu gravatar image

updated 2016-10-24 09:10:03 -0600

ngrennan gravatar image

Does anyone know what or when to expect the new XBOX One Kinect sensor to work with ROS (Openni2?)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
9

answered 2014-01-20 08:01:14 -0600

tbh gravatar image

updated 2014-09-26 09:30:20 -0600

EDIT : Thiemo from the Institute for Artificial Intelligence at the University of Bremen has released a kinect v2 driver! Check out this post from ROS news for more info.

The folks over at openkinect seem to be hard at work in hacking kinect v2. There's not much info on the wiki page as of this post, but some of the threads on the forums are quite encouraging.

edit flag offensive delete link more

Comments

3

Any update on this?

isura gravatar imageisura ( 2014-07-10 09:40:16 -0600 )edit

Anyone managed to get the skeleton tracking with the Kinect v2 ? that would be awesome^^!

Cyril_J gravatar imageCyril_J ( 2014-12-12 11:31:39 -0600 )edit

Any update on the new kinect (kinect for xbpx one) ? Has anyone managed to get it run.? Would highly appreciate your help regarding the same.

srik11 gravatar imagesrik11 ( 2016-01-17 20:29:57 -0600 )edit
1

I got it working on Ubuntu 14.04 and ROS Indigo up to the point where I can see the colored point cloud in Rviz. I think you just have to follow the instructions here : https://github.com/code-iai/iai_kinect2

Cyril_J gravatar imageCyril_J ( 2016-01-18 08:37:42 -0600 )edit

Hey, I tried the same. I installed libfreenect2. But for me the issue is that I cannot even run with Protonect. So I was wondering whether my USB controller has any issue. I get no devices found when I run Protonect. Although the USB port is USB 3.0. Which USB controller are you using?

srik11 gravatar imagesrik11 ( 2016-01-18 19:59:42 -0600 )edit

I also use USB3.0. Do you see the kinect listed with the lsusb command ? Did you try to run Protonect with the options gl, cl or cpu ?

Cyril_J gravatar imageCyril_J ( 2016-01-19 02:03:47 -0600 )edit

Hey!, Thanks, found the issue. libusb was not the latest version. But now Protonect runs with cpu and gl but does not run with cl. I am guessing opencl is not completely installed. I have an intel GPU, so i am not able to install beignet. for my kernel 3.16. Did you face this issue?

srik11 gravatar imagesrik11 ( 2016-01-20 08:57:09 -0600 )edit

In the beginning I also had issues, I saw only black windows with no data I remember. I have a nVidia GPU. There was a rely I gave, you can have a look : http://answers.ros.org/question/20939... Did you get the kinect2_bridge working ?

Cyril_J gravatar imageCyril_J ( 2016-01-20 09:30:02 -0600 )edit
2

answered 2013-12-15 20:40:50 -0600

tfoote gravatar image

The XBox One Kinect is completely different technology from the XBox 360 Kinect. It will not work with openni2. Someone is going to need to reverse engineer the new Kinect's protocol again unless Microsoft releases a linux SDK. (Not likely.)

edit flag offensive delete link more

Comments

Does anybody know if someone started working on this?

BennyRe gravatar imageBennyRe ( 2013-12-15 23:42:24 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

7 followers

Stats

Asked: 2013-12-10 08:53:32 -0600

Seen: 10,532 times

Last updated: Sep 26 '14