Ask Your Question
0

camera_prosilica: setting whitebalance_red/blue fails

asked 2011-08-09 20:19:27 -0500

Daniel Eberli gravatar image

Hi there

I've a fresh install of ROS (desktop-full) with camera drivers. I successfully can stream from a Prosilica GC655C and set/get parameters with, e.g., dynamic_reconfigure. The only parameter I can't set is 'whitebalance_red' and 'whitebalance_blue'. Of course, 'auto_whitebalance' is set to off.

setting the whitebalance values directly with the SampleViewer it works, but not trough ROS. Even setting the parameter by rosparam doesn't work.

Do you have an idea how to make it work?

Best, Dani

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-08-10 04:42:16 -0500

Daniel Eberli gravatar image

updated 2011-08-24 22:49:10 -0500

I found the solution to the problem:

in the prosilica library (prosilica.cpp) in function Camera::setWhiteBalance the test, whether manual whitebalance is available

PvAttrIsAvailable(handle_, "WhitebalValueBlue")

returns 0 (ePvErrSuccess) if manual whitebalance for blue is available. since the whitebal check is

if (isauto == Manual && PvAttrIsAvailable(handle_, "WhitebalValueBlue"))

it will FAIL if the PvAttrIsAvailable returns ePvErrSuccess.

if (isauto == Manual && ePvErrSuccess == PvAttrIsAvailable(handle_, "WhitebalValueBlue"))

will solve the problem.

edit flag offensive delete link more

Comments

Thanks Daniel. Could you please open a ticket (go to http://www.ros.org/wiki/camera_drivers and click the "report bugs" link at the bottom) to make sure this issue doesn't get lost.
Patrick Mihelich gravatar image Patrick Mihelich  ( 2011-08-11 10:12:25 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-08-09 20:19:27 -0500

Seen: 129 times

Last updated: Aug 24 '11