PR2 Spinning, obstacle_range parameter [closed]

asked 2011-08-01 18:15:04 -0600

zxie gravatar image

updated 2011-08-07 14:28:41 -0600

Hi,

We've been having trouble getting our PR2 to navigate between a few stations. We can see in Rviz that a path is found when we set a goal, but then the PR2 begin spinning in place continuously (in one direction), even when it would seem perfectly reasonable to continue along its path and there are no immediate obstructions. If we set a 2d nav goal a good distance from any station, however, it seems to head there without much issue.

We also found that by setting the obstacle_range parameter in costmap_params_common.yaml in the pr2_navigation_config package to some low value (e.g. 0.05), the previous issue went away, but obstacles detected by the tilting laser wouldn't be registered.

Any advice on parameters to tune would be appreciated. We're using Diamondback with the default configurations. Thanks!

EDIT: Our problem seems to have been solved. We changed the base_local_planner from DWAPlannerROS to TrajectoryPlannerROS. Still not entirely sure as to the issue.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by kwc
close date 2012-02-29 07:52:48

Comments

On occasion, I have seen the PR2 spin weirdly with the dwa_local_planner. However, its never been infinite, and I've never been able to reliably reproduce it. I'm glad that the base_local_planner works for you for now, but perhaps I'll try to take another shot at tracking down what might be wrong.
eitan gravatar image eitan  ( 2011-08-08 05:43:00 -0600 )edit
I've seen exactly the same problem. I will test your solution and report back.
Lorenzo Riano gravatar image Lorenzo Riano  ( 2011-08-09 21:02:31 -0600 )edit