Ask Your Question
0

No transform from [right_leg] to [/base_link]

asked 2011-08-01 07:33:12 -0500

Vinipsmaker gravatar image

I was developing my URDF robot model, using ros tutorials as reference, and got my second error (the first was this).

I'm using exactly multipleshapes example, but when I try it, this error happens: "right_leg No transform from [right_leg] to [/base_link]"

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2011-08-02 10:05:33 -0500

Wim gravatar image

You should try out some of the debugging approaches laid out in the tf wiki troubleshooting page.

edit flag offensive delete link more

Comments

Okay, I'll debug, but I'm using the same code as the tutorial. It MUST work. The tutorial can't teach us wrong. NOTE: I can't install the urdf_tutorial package, so I'm running using the simples command "rosrun rviz rviz"
Vinipsmaker gravatar imageVinipsmaker ( 2011-08-02 15:04:37 -0500 )edit

@Vinipsmaker. I ran into the same problem when doing the tutorial. Did you ever manage to figure out what went wrong? I tried to debug but tf_echo gives no output and tf_monitor says "tf_monitor waiting for time to be published". I use Indigo btw.

tropic gravatar imagetropic ( 2014-11-21 14:43:01 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-08-01 07:33:12 -0500

Seen: 1,838 times

Last updated: Aug 02 '11