Ask Your Question
1

rviz does not start, prints "GLXUnsupportedPrivateRequest"

asked 2011-07-13 03:55:45 -0500

JFReuter gravatar image

When I try to run rviz, I get the following output:

[reuter@fahrsim04:~]$ rosrun rviz rviz                                                                                                                                                                             (07-13 17:48)
Xlib:  extension "NV-GLX" missing on display ":0.0".
[ INFO] [1310572108.380121383]: Loading general config from [/fzi/ids/reuter/.rviz/config]
[ INFO] [1310572108.380396700]: Loading display config from [/fzi/ids/reuter/.rviz/display_config]
The program 'rviz' received an X Window System error.
This probably reflects a bug in the program.
The error was 'GLXUnsupportedPrivateRequest'.
  (Details: serial 21 error_code 177 request_code 155 minor_code 16)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
[reuter@fahrsim04:~]$

...and the program doesn't run.

Notes:

I get the message Xlib: extension "NV-GLX" missing on display ":0.0". for every glx program I run. I have not been able to determine what is causing this, as this system is using an intel card with an intel driver. All the programs work fine, though, and glxinfo reports that direct rendering is enabled.

A google search about the error has not yielded a solution.

What can I do to get rviz to work?

edit retag flag offensive close merge delete

Comments

are you running inside a virtual machine?
Asomerville gravatar image Asomerville  ( 2011-07-13 09:58:08 -0500 )edit
@Asomerville No, this is on a dedicated Kubuntu machine.
JFReuter gravatar image JFReuter  ( 2011-07-14 01:36:09 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
5

answered 2011-07-17 22:02:18 -0500

Tobias gravatar image

Hi mate,

Xlib: extension "GLX" missing on display ":0.0" is more linux related. Try:

sudo apt-get purge nvidia*
sudo apt-get install --reinstall xserver-xorg-video-intel  libgl1-mesa-glx libgl1-mesa-dri    server-xorg-core
sudo dpkg-reconfigure xserver-xorg
sudo update-alternatives --remove gl_conf /usr/lib/nvidia-current/ld.so.conf

(see https://theiszm.wordpress.com/2010/06/27/glx-missing-on-display/). Do not worry about removing ros packages. You can reinstall them afterwards.

Regards, Tobias

edit flag offensive delete link more

Comments

That worked! Turns out the nvidia packages _were_ interferring with the 3d acceleration. Now I do not have the error anymore and rviz works like a charm. You have some serious psychic debugging skills :-)
JFReuter gravatar image JFReuter  ( 2011-07-17 22:44:04 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-07-13 03:55:45 -0500

Seen: 1,438 times

Last updated: Jul 17 '11