Ask Your Question
0

problem installing turtlebot on ros-groovy

asked 2013-11-28 01:27:38 -0500

Maikel gravatar image

updated 2013-11-28 20:12:49 -0500

bit-pirate gravatar image

Hi,

I have installed ubuntu 12.04 and ros-groovy and when I try to install turtlebot package I get the following problem:

viki@ROS:~$ sudo apt-get install ros-groovy-turtlebot
[sudo] password for viki: 

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 ros-groovy-turtlebot : Depends: ros-groovy-zeroconf-avahi-suite (= 0.2.2-0precise-20131015-2213-+0000) but it is not going to be installed
                        Depends: ros-groovy-navigation (= 1.10.3-s1383961963~precise) but it is not going to be installed
                        Depends: ros-groovy-multimaster-experimental (= 0.2.1-s1381889748~precise) but it is not going to be installed
                        Depends: ros-groovy-xacro (= 1.7.4-s1381889842~precise) but it is not going to be installed
                        Depends: ros-groovy-ros-comm (= 1.9.50-0precise-20131016-0131-+0000) but 1.9.39-0precise-20121230-1434-+0000 is to be installed
                        Depends: ros-groovy-turtlebot-create (= 2.0.1-s1381895136~precise) but it is not going to be installed
                        Depends: ros-groovy-kobuki (= 0.3.9-1precise-20131016-0554-+0000) but it is not going to be installed
                        Depends: ros-groovy-kobuki-description (= 0.3.2-s1381895153~precise) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Please, Can help me someone to resolve this problem? I don't know what should I do. thanks,

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-11-28 20:23:49 -0500

bit-pirate gravatar image

This looks like more a Linux/Ubuntu problem to me. One or more dependencies of one or more of the packages you are going to install are causing troubles. You need to locate those dependencies to find out more about the problem you are actually having.

synaptic and aptitude may help here.

Other options are: You recently made changes in the depositories/depository list you are getting the packages from. E.g. package depends on version X.Y, but available is only X.(Y-1). I get that sometimes, when switching my Ubuntu repos to non-default, but faster ones.

Btw, are you running 32bit or 64bit?

edit flag offensive delete link more

Comments

sorry by the delay, I was tripping and I didn't had connection. You are right I had a problem with my repository configuration, thank you very much for your help, I fix it and now it work. Thank again.

Maikel gravatar image Maikel  ( 2013-12-03 00:31:44 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-11-28 01:27:38 -0500

Seen: 117 times

Last updated: Nov 28 '13