Ask Your Question
0

arm_navigation visualization error: No default planner configuration defined under 'default_planner_config'. A default planner must be defined from among the configured planners

asked 2011-07-08 02:10:45 -0500

Pi Robot gravatar image

updated 2011-07-08 02:17:07 -0500

Hello ROS Wizards,

I am trying out the new (and incredibly awesome) arm navigation planning wizard on my home built robot (Pi Robot). The wizard runs flawlessly and I generated a planning group called "left arm" that runs from the torso link to the left hand link.

Next I wanted to try the planning components visualizer so I launched the automatically created planning_components_visualizer.launch file. Most of the nodes fired up fine until I ran into the following error:

No default planner configuration defined under 'default_planner_config'. A default planner must be defined from among the configured planners

The full output from the launch file looks like this:

core service [/rosout] found
process[wall_clock_server-1]: started with pid [2005]
process[environment_server-2]: started with pid [2006]
process[planning_scene_validity_server-3]: started with pid [2007]
process[pi_robot_left_arm_kinematics-4]: started with pid [2008]
process[ompl_planning-5]: started with pid [2009]
process[trajectory_filter_server-6]: started with pid [2010]
process[rviz_planning_components-7]: started with pid [2011]
process[planning_components_visualizer-8]: started with pid [2012]
process[rob_st_pub-9]: started with pid [2013]
[ INFO] [1310134526.200470474, 1310134526.196687936]: Environment server started
[ INFO] [1310134526.269147358, 1310134526.258922100]: waitForService: Service [/ompl_planning/plan_kinematic_path] has not been advertised, waiting...
[ INFO] [1310134526.544622151, 1310134526.542999029]: Successfully connected to planning scene action server for /planning_scene_validity_server
[ INFO] [1310134526.544764147, 1310134526.542999029]: Successfully connected to planning scene action server for /ompl_planning
[ INFO] [1310134526.746567756, 1310134526.741112947]: Successfully connected to planning scene action server for /pi_robot_left_arm_kinematics
[ INFO] [1310134526.848666707, 1310134526.845432043]: Successfully connected to planning scene action server for /trajectory_filter_server
[ INFO] [1310134527.267298212, 1310134527.264225959]: Waiting for planner service /ompl_planning/plan_kinematic_path
[ INFO] [1310134527.268940800, 1310134527.264225959]: waitForService: Service [/ompl_planning/plan_kinematic_path] has not been advertised, waiting...
[ERROR] [1310134527.285647063, 1310134527.274550914]: No default planner configuration defined under 'default_planner_config'. A default planner must be defined from among the configured planners

Any thoughts on how I can fix this?

Thanks!
patrick

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-07-08 06:36:36 -0500

Sachin Chitta gravatar image

Add the following line at the end of your auto-generated YAML configuration file for OMPL (config/ompl_planning.yaml):

default_planner_config: SBLkConfig1

We'll update the gui soon so it reflects this change and adds the line in automatically.

edit flag offensive delete link more

Comments

Thanks Sachin--works like a charm now!
Pi Robot gravatar imagePi Robot ( 2011-07-08 07:42:46 -0500 )edit
Fixed on trunk, will be released shortly. Sorry for the omission!
egiljones gravatar imageegiljones ( 2011-07-11 10:47:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2011-07-08 02:10:45 -0500

Seen: 376 times

Last updated: Jul 08 '11