Ask Your Question
1

How do I create a ROS enabled Android app?

asked 2013-11-26 00:24:13 -0500

MariosV gravatar image

Hello, I'm a newbie on ROS and ROSJava and I'm trying write an app which communicates with ROS on a PC. The PC has ROS Hydro installed. I've followed the steps so now I have rosjava_core and android_core. And I was trying to import the tutorials from android_core in Android Studio to test the waters and start playing around but I get a message about unsupported version of Gradle (which is weird because it's using the one that came with AS). I have v1.8 of Gradle. When I am not getting that problem I get "Could not find any version that matches org.ros.rosjava_bootstrap:gradle_plugins:[0.1,0.2).Required by:android_core:unspecified" I've followed the tutorials as closely as possible but I can't seem to find a solution. Any help would be very appreciated.

edit retag flag offensive close merge delete

Comments

After a lot of messing around and your help I managed to solve my problems. a) I was sourcing the wrong setup.bash file so I got the "Could not find..." problem. b) The Gradle problem seemingly solved itself. Thanks a lot.

MariosV gravatar image MariosV  ( 2014-02-09 06:18:15 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-11-27 10:49:06 -0500

dtc gravatar image

For the Gradle version, try to change the Gradle version number in the wrapper folder of android_core (android_core/gradle/wrapper/gradle....properties).
For the rojava_bootstrap... error check this post //answers.ros.org/question/100271/importing-android_core-failed/

edit flag offensive delete link more

Comments

This answer help me. Thanks Dtc. What exactly I did: 1. I installed Gradle 1.9 (not 1.10!) 2. Cloned android_core 3. cd .../android_core/android_tutorial_camera 4. catkin_make 5. source devel/setup.bash 6. .../android-studio/bin/studio.sh 7. Then selected "Import project" and android_code directory

DmitryDzz gravatar image DmitryDzz  ( 2014-01-08 03:35:37 -0500 )edit
0

answered 2014-01-07 05:26:46 -0500

updated 2014-01-07 07:01:41 -0500

I've got the same error in Ubuntu 12.04, ROS Hydro and Gradle 1.10. So I tried to change "android_core/gradle/wrapper/gradle-wrapper.properties". And I changed distributionUrl parameter from "gradle-1.9-bin.zip" to "gradle-1.10-bin.zip". But it didn't help.

edit flag offensive delete link more

Comments

Thanks Dtc. It did help! My problem was in Gradle 1.10. I found the answer on stackoverflow: http://stackoverflow.com/questions/20812703/cant-find-org-gradle-api-artifacts-result-resolvedmoduleversionresult-when-appl. After I downgrade gradle from 1.10 to 1.9 I could finally build android_core.

DmitryDzz gravatar image DmitryDzz  ( 2014-01-08 03:20:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-11-26 00:24:13 -0500

Seen: 1,120 times

Last updated: Nov 27 '13