Ask Your Question
0

ROS MoveIt PR2 Demo Launch Fails following tutorial

asked 2013-11-21 05:11:09 -0500

dragowill gravatar image

updated 2014-04-20 14:09:26 -0500

ngrennan gravatar image

Hi everyone, I am a newbie and was trying to follow the tutorial from here:moveit.ros.org/wiki/PR2/Rviz_Plugin/Quick_Start and when I tried launching roslaunch pr2_moveit_config demo.launch, I would get this message below:

All is well! Everyone is happy! You can start planning now!

[rviz_cehd_1050011_7612_1188156060-6] process has died [pid 7687, exit code -11, cmd /opt/ros/hydro/lib/rviz/rviz -d /opt/ros/hydro/share/pr2_moveit_config/launch/moveit.rviz __name:=rviz_cehd_1050011_7612_1188156060 __log:=/home/willi/.ros/log/50fcfb64-52ca-11e3-b7fb-0024e8bf7cc6/rviz_cehd_1050011_7612_1188156060-6.log]. log file: /home/willi/.ros/log/50fcfb64-52ca-11e3-b7fb-0024e8bf7cc6/rviz_cehd_1050011_7612_1188156060-6*.log

I searched around and it is a similar message but not exactly the same on this one://answers.ros.org/question/75769/ros-moveit-pr2-demo-launch-fails/. It fails at the end after saying all is well etc.

I just reinstall Ubuntu 12.0.4 64 bit because I thought my previous Ubuntu 12.0.4 32 bit is not working (always getting the same error 11) so I just freshly installed ROS Hydro, MoveIt and PR2 full and it is still failing and it's only a tutorial.

Can anyone give me an insights on what to do next? Thanks a lot.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-11-21 12:20:18 -0500

Pi Robot gravatar image

This is a total guess, but I experienced similar crashes with MoveIt on various machines and it turned out to be RViz rather than MoveIt that is crashing. This seems to happen more often when RViz is trying to use hardware acceleration, so try turning telling RViz to use software rendering only before launching the PR2 MoveIt demo file like this:

$ export LIBGL_ALWAYS_SOFTWARE=1
$ roslaunch pr2_moveit_config demo.launch

--patrick

edit flag offensive delete link more

Comments

Hi Patrick, thanks for responding. That seems to work for launching pr2 demo.launch now. However, every time I close Rviz that error message would show and have to use ctrl c to get out of it from the terminal. Do you think it's a good idea to put LIBGL_ALWAYS_SOFTWARE=1 in .bashrc? Thanks. --willi

dragowill gravatar image dragowill  ( 2013-11-21 14:11:59 -0500 )edit

Glad that got you going. I also have to Ctrl-C to exit MoveIt completely after closing RViz--not sure if others are experiencing the same thing. I have "export LIBGL_ALWAYS_SOFTWARE=1" in my .bashrc since I was getting tired of RViz crashing. You can do an "unset LIBGL_ALWAYS_SOFTWARE" in a given terminal if you want to override it on the fly.

Pi Robot gravatar image Pi Robot  ( 2013-11-21 14:52:29 -0500 )edit

Awesome. Thanks! and I just realized that it is mentioned on top of this page:wiki.ros.org/rviz/Troubleshooting and found out that my laptop has Intel Mobile 4 Graphics Controller. so I am definitely will put it in my .bashrc.

dragowill gravatar image dragowill  ( 2013-11-21 15:36:13 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-11-21 05:11:09 -0500

Seen: 722 times

Last updated: Nov 21 '13