Ask Your Question
0

No longer able to checkout opencv_candidate in revision 50974, how is this possible?

asked 2011-06-04 08:09:29 -0500

Julius gravatar image

updated 2011-06-04 08:19:46 -0500

Where to find SVN repository for package opencv_candidate? I did a SVN checkout a couple of weeks ago, but the SVN URL is no longer valid.

I am using package opencv_candidate in SVN revision 50974. It seems that the URL to https://code.ros.org/svn/wg-ros-pkg/branches/trunk_diamondback/stacks/vision_bleeding/opencv_candidate is no longer valid, and now just returns "HTTP 404 Not Found". It worked for the last months. If you look at https://code.ros.org/svn/wg-ros-pkg/branches/trunk_diamondback/stacks, there's not even vision_bleeding to be found.

Now, the following behaviour is puzzling me.

svn co https://code.ros.org/svn/wg-ros-pkg/b...

fails with

svn: URL 'https://code.ros.org/svn/wg-ros-pkg/branches/trunk_diamondback/stacks/vision_bleeding/opencv_candidate' doesn't exist

which might be OK, since this sub-directory in the wg-ros-pkg might have been deleted in a commit after 50974, yet

svn co -r 50974 https://code.ros.org/svn/wg-ros-pkg/b...

fails with

svn: '/svn/wg-ros-pkg/!svn/bc/51716/branches/trunk_diamondback/stacks/vision_bleeding/opencv_candidate' path not found

whilst on my SVN working copy (that I've checked out way earlier) the following works

svn info

properly printing

Path: .

URL: https://code.ros.org/svn/wg-ros-pkg/b...

Repository Root: https://code.ros.org/svn/wg-ros-pkg

Repository UUID: 7275ad9f-c29b-430a-bdc5-66f4b3af1622

Revision: 50974

[...]

and also

svn update -r 51400

actually retrieves files and prints as expected

At revision 51400.

Puzzling though that

svn update

leads to

svn: Target path does not exist

Finally, I just want to retrieve opencv_candidate in revision 50479 (it should not disappear from history, right?), but rosinstall will fail to retrieving opencv_candidate in that revision. What am I doing wrong here? Anybody else using opencv_candidate, and having similar issues?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2011-06-04 09:23:50 -0500

tfoote gravatar image

The directory was renamed, see this answer http://answers.ros.org/question/1042/vision_bleeding-not-found.

If you want to checkout the old version you have to use different syntax. (It's an odd bug in the svn client.)

svn co https://code.ros.org/svn/wg-ros-pkg/branches/trunk_diamondback/stacks/vision_bleeding/opencv_candidate@50974
edit flag offensive delete link more

Comments

Thanks, that solved the issue! Your response made me do further research (this time on SVN). It's not a bug! See http://svnbook.red-bean.com/en/1.5/svn.advanced.pegrevs.html . So, I will have to take the blame, and the SVN client actual works correctly here!
Julius gravatar image Julius  ( 2011-06-04 09:49:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2011-06-04 08:09:29 -0500

Seen: 371 times

Last updated: Jun 04 '11