Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

As I assumed, it's a namespace problem. Your observation_sources parameter is defined outside of the corresponding namespace of the layer plugin.

Change this...

observation_sources: laser

to this:

obstacle_layer:
  observation_sources: laser

... assuming that your launch file sets the correct namespace for the load parameter of the move_base node (like in the move_base tutorial).

Generally speaking, imho this should be explicitly mentioned somewhere in the Groovy->Hydro migration tutorial for move_base and costmap_2d since I ran into the very same problem and I guess @CarolineQ and me are not the only ROS noobs who make this experience.