Ask Your Question

Revision history [back]

binvox sometimes behaves strange, maybe it ignores the bounding box in a later step. As a first measure, I would get the latest version from the author's homepage (future versions of OctoMap will no longer contain binvox binaries anyways) and see if the problem is resolved with it.

I usually had good results with binvox using the -v or -e options, ignoring -bb. Instead, try using the --bb and --offset parameters of binvox2bt, that worked more reliable.

To verify whether the intermediate binvox file is OK you can use viewvox, and then octovis to verify the final .bt output.