Ask Your Question

Revision history [back]

click to hide/show revision 1
initial version

You may have multiple versions of rtabmap. rtabmap-databaseViewer is installed with the binaries. To make it simple, remove rtabmap installed by source, then make sure you upgrade both ros-kinetic-rtabmap and ros-kinetic-rtabmap-ros packages to latest version:

$ sudo rm -r /usr/local/bin/rtabmap*
$ sudo rm -r /usr/local/lib/rtabmap*
$ sudo rm -r /usr/local/lib/librtabmap*
$ sudo rm -r /usr/local/include/rtabmap*

$ sudo apt-get install ros-kinetic-rtabmap-ros ros-kinetic-rtabmap

cheers,
Mathieu