hector_quadrotor catkin_make error

asked 2013-11-10 06:34:10 -0500

End-Effector gravatar image

updated 2013-11-14 12:31:42 -0500

tfoote gravatar image

I'm trying to use the catkin version of hector_quadrotor.

https://github.com/tu-darmstadt-ros-pkg/hector_quadrotor/tree/catkin.

When I do the catkin_make I get a cmake fail.

paulo@ubuntu:~/hector_quad$ catkin_make

Base path: /home/paulo/hector_quad Source space: /home/paulo/hector_quad/src Build space: /home/paulo/hector_quad/build Devel space: /home/paulo/hector_quad/devel Install space: /home/paulo/hector_quad/install Creating symlink "/home/paulo/hector_quad/src/CMakeLists.txt" pointing to "/opt/ros/hydro/share/catkin/cmake/toplevel.cmake" ####

Running command: "cmake /home/paulo/hector_quad/src -DCATKIN_DEVEL_PREFIX=/home/paulo/hector_quad/devel -DCMAKE_INSTALL_PREFIX=/home/paulo/hector_quad/install" in "/home/paulo/hector_quad/build"

#### -- The C compiler identification is GNU -- The CXX compiler identification is GNU -- Check for working C compiler: /usr/bin/gcc -- Check for working C compiler: /usr/bin/gcc -- works -- Detecting C compiler ABI info -- Detecting C compiler ABI info - done -- Check for working CXX compiler: /usr/bin/c++ -- Check for working CXX compiler: /usr/bin/c++ -- works -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Using CATKIN_DEVEL_PREFIX: /home/paulo/hector_quad/devel -- Using CMAKE_PREFIX_PATH: /opt/ros/hydro -- This workspace overlays: /opt/ros/hydro -- Found PythonInterp: /usr/bin/python (found version "2.7.3") -- Using Debian Python package layout -- Using CATKIN_ENABLE_TESTING: ON -- Call enable_testing() -- Using CATKIN_TEST_RESULTS_DIR: /home/paulo/hector_quad/build/test_results -- Looking for include files CMAKE_HAVE_PTHREAD_H -- Looking for include files CMAKE_HAVE_PTHREAD_H - found -- Looking for pthread_create in pthreads -- Looking for pthread_create in pthreads - not found -- Looking for pthread_create in pthread -- Looking for pthread_create in pthread - found -- Found Threads: TRUE -- Found gtest sources under '/usr/src/gtest': gtests will be built -- catkin 0.5.77 -- BUILD_SHARED_LIBS is on -- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ -- ~~ traversing 10 packages in topological order: -- ~~ - hector_quadrotor -- ~~ - hector_quadrotor_demo -- ~~ - hector_quadrotor_description -- ~~ - hector_quadrotor_gazebo -- ~~ - hector_quadrotor_teleop -- ~~ - hector_uav_msgs -- ~~ - hector_quadrotor_controller -- ~~ - hector_quadrotor_model -- ~~ - hector_quadrotor_gazebo_plugins -- ~~ - hector_quadrotor_pose_estimation -- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ -- +++ processing catkin package: 'hector_quadrotor' -- ==> add_subdirectory(hector_quadrotor) -- +++ processing catkin package: 'hector_quadrotor_demo' -- ==> add_subdirectory(hector_quadrotor_demo) -- +++ processing catkin package: 'hector_quadrotor_description' -- ==> add_subdirectory(hector_quadrotor_description) -- +++ processing catkin package: 'hector_quadrotor_gazebo' -- ==> add_subdirectory(hector_quadrotor_gazebo) -- +++ processing catkin package: 'hector_quadrotor_teleop' -- ==> add_subdirectory(hector_quadrotor_teleop) -- +++ processing catkin package: 'hector_uav_msgs' -- ==> add_subdirectory(hector_uav_msgs) -- hector_uav_msgs: 21 messages, 0 services -- +++ processing catkin package: 'hector_quadrotor_controller' -- ==> add_subdirectory(hector_quadrotor_controller) -- +++ processing catkin package: 'hector_quadrotor_model' -- ==> add_subdirectory(hector_quadrotor_model) CMake Warning at hector_quadrotor_model/matlab/CMakeLists.txt:24 (message): Matlab not found

CMake Warning at hector_quadrotor_model/CMakeLists.txt:49 (message): Quadrotor model is not available. Skipping target hector_quadrotor_propulsion...

CMake Warning at hector_quadrotor_model/CMakeLists.txt:61 (message): Quadrotor model is not available. Skipping target hector_quadrotor_aerodynamics...

-- +++ processing catkin package: 'hector_quadrotor_gazebo_plugins' -- ==> add_subdirectory(hector_quadrotor_gazebo_plugins) CMake Error at /opt/ros/hydro/share/catkin/cmake/catkinConfig.cmake:72 (find_package): Could not find a configuration file for package hector_gazebo_plugins.

Set hector_gazebo_plugins_DIR to the directory containing a CMake configuration file for hector_gazebo_plugins. The file will have one of the following names:

hector_gazebo_pluginsConfig.cmake
hector_gazebo_plugins-config.cmake

Call Stack (most recent call first): hector_quadrotor_gazebo_plugins/CMakeLists.txt:7 (find_package)

-- checking for module 'gazebo' -- found gazebo, version 1.9.1 CMake Warning at hector_quadrotor_gazebo_plugins/CMakeLists.txt:72 (message): Quadrotor propulsion model is not available. Skipping target hector_gazebo_quadrotor_propulsion...

CMake Warning at hector_quadrotor_gazebo_plugins/CMakeLists.txt:79 (message): Quadrotor aerodynamics model is not available. Skipping target hector_gazebo_quadrotor_aerodynamics...

-- +++ processing catkin package: 'hector_quadrotor_pose_estimation' -- ==> add_subdirectory(hector_quadrotor_pose_estimation) CMake Error at /opt/ros/hydro ... (more)

edit retag flag offensive close merge delete

Comments

I am trying to download this build but ran into an error when doing git clone fatal: https://github.com/tu-darmstadt-ros-pkg/hector_quadrotor/tree/catkin/info/refs?service=git-upload-pack not found: did you run git update-server-info on the server? How did you overcome this?

Quadrobo gravatar imageQuadrobo ( 2013-11-11 23:28:56 -0500 )edit

If you click on the link in my post you should go to the page of hector_quadrotor catkin version, with no problems. Then you only have to click on download zip.

End-Effector gravatar imageEnd-Effector ( 2013-11-11 23:47:39 -0500 )edit

Thanks for the tip. I have built it and have not experienced the said error.

Quadrobo gravatar imageQuadrobo ( 2013-11-12 05:44:41 -0500 )edit

Did you use catkin_make? No "Could not find a configuration file for package hector_pose_estimation"? I don't understand what I did wrong then.

End-Effector gravatar imageEnd-Effector ( 2013-11-12 06:59:19 -0500 )edit

I used catkin_make cmd. Though having compiled it, ros was still not able to find the demo launch file though it is still there. I am thinking that it is not as simple as it seems.

Quadrobo gravatar imageQuadrobo ( 2013-11-12 21:30:39 -0500 )edit

after compiling you have to do that command in your workspace (source devel/setup.bash) then you can do that roslaunch package_name launch_file_name.launch. Hope this helps you.

End-Effector gravatar imageEnd-Effector ( 2013-11-13 04:53:54 -0500 )edit

After putting the hector_quadrotor into the src folder and recompiling it, I encountered the same error as yours ... The difference is mine stopped at gazebo_plugins

Quadrobo gravatar imageQuadrobo ( 2013-11-15 00:07:09 -0500 )edit

yeah.. I talked to the guy that did hector_quadrotor, and You need some other packages for this to work. You basically need some of the other hector packages. He did for me to just use the one you install automatically, from the ubuntu repository

End-Effector gravatar imageEnd-Effector ( 2013-11-15 00:51:37 -0500 )edit