Ask Your Question
0

Missing resource ccny_rgbd_tools

asked 2013-10-17 22:37:18 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hi, i'm trying to install ccny_rgdb_tools so that i can make the mapping of a room with a kinect camera. When i reached the comand "Install any dependencies using rosdep:" it gives me the following error.

duarte@duarte-Aspire-V3-551G:~$ rosdep install ccny_rgbd_tools ERROR: Rosdep cannot find all required resources to answer your query Missing resource ccny_rgbd_tools ROS path [0]=/opt/ros/groovy/share/ros ROS path [1]=/home/duarte/ros ROS path [2]=/opt/ros/groovy/share/ ROS path [3]=/opt/ros/groovy/stacks/

How can i fix this? please help. Thank you very much.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2013-10-19 18:13:30 -0500

tfoote gravatar image

updated 2013-10-21 08:57:44 -0500

rosdep install installs system dependencies of a package it expects to find already installed on your system. Make sure you have followed all the steps earlier in whatever tututorial you're following(ps please link to the tutorial you are following).

Update:

The tutorial you link to is not quite linear to copy and paste and follow. I think you're missing this step called out at the top:

and make sure it's added to your$ROS_PACKAGE_PATH.

edit flag offensive delete link more

Comments

http://wiki.ros.org/rosdep - this is the tutorial i followed to install rosdep. It doesnt give me any type of errors or warnings. https://github.com/ccny-ros-pkg/ccny_rgbd_tools- is the turotial i used to install ccny-ros-pkg

sigmaduarte gravatar image sigmaduarte  ( 2013-10-21 06:08:51 -0500 )edit

@sigmaduarte : I agree with tfoote, I think you have forgotten to add the ccny package to your ROS_PACKAGE_PATH. I am trying to install it to and I manage this step but have a compilation error "rgbd_frame.cpp:276:69: erreur: no match for ‘operator=’ in ‘cloud.pcl::PointCloud<pcl::pointxyz>::header.std_msgs........" Keep me up to date if you have the same problem or not. Thanks

CarolineQ gravatar image CarolineQ  ( 2013-10-21 22:30:34 -0500 )edit

It worked untill i tried the comand rosmake ccny_rgbd_tools. I get the same exact error that you get, @CarolineQ : did you find out how to fix it?

sigmaduarte gravatar image sigmaduarte  ( 2013-10-24 07:34:50 -0500 )edit

Thanks for your answer, it's important to know that other people have the same error. I didn't find how to fix it but I opened a new question here http://answers.ros.org/question/93096/ccny_rgbd-compilation-error/ and here https://github.com/ccny-ros-pkg/ccny_rgbd_tools/issues/28

CarolineQ gravatar image CarolineQ  ( 2013-10-24 21:07:11 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-10-17 22:37:18 -0500

Seen: 614 times

Last updated: Oct 21 '13