Ask Your Question
0

Install turtelbot simulator on mac os ?

asked 2013-10-11 03:05:20 -0500

schitic gravatar image

updated 2013-10-11 05:26:29 -0500

How to install turtlebot on mac os ? I have tried to complie the source from github and when I run rosdep install --from-paths src -i -y I get

the following packages/stacks could not have their rosdep keys resolved
to system dependencies:
kobuki_ftdi: No definition of [ftdi-eeprom] for OS [osx]
kobuki_qtestsuite: No definition of [pyqt4-dev-tools] for OS [osx]

Any ideas ?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-10-11 05:30:29 -0500

The error is telling you that it doesn't know how to install two required system dependencies because they don't have rosdep keys for OSX.

If you can figure out how to install these dependencies with homebrew or pip, you can fork rosdistro, add the keys, and submit a pull request.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-10-11 03:05:20 -0500

Seen: 165 times

Last updated: Oct 11 '13