Ask Your Question
1

OSX Install problem - rqt_top: No definition of [python-psutil] for OS [osx]

asked 2013-09-17 19:47:51 -0500

iandanforth gravatar image

updated 2013-09-23 01:13:21 -0500

130s gravatar image

Hello! I'm trying to walk through the latest OSX install instructions. I have gotten to this step:

rosdep install --from-paths src --ignore-src --rosdistro hydro -y

When I encountered this error:

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: rqt_top: No definition of [python-psutil] for OS [osx]

I'm on 10.8.3 and this is the first time I've tried to install ROS on this laptop. (If that matters)

Suggestions for debugging ideas would be appreciated!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-09-18 00:11:00 -0500

130s gravatar image

updated 2013-09-23 23:28:54 -0500

Update 9/23/2013) patch is accepted and the reported issue should not longer be the case.


That's because psutil is missing in OSX' rosdep key.


Here is tentative workaround before the rosdep key gets updated. Since this involves modifying protected area, do it at your own risk.

I have a patch that I haven't submitted since I haven't tested on my local Mac. If you can try (eg. by doing the following steps) that would be great.

Make a backup and modify /etc/ros/rosdep/sources.list.d/20-default.list as follows:

Current: yaml <a href="https://github.com/ros/rosdistro/raw/master/rosdep/osx-homebrew.yaml">https://github.com/ros/rosdistro/raw/master/rosdep/osx-homebrew.yaml</a> osx
New: yaml <a href="https://github.com/130s/rosdistro/raw/master/rosdep/osx-homebrew.yaml">https://github.com/130s/rosdistro/raw/master/rosdep/osx-homebrew.yaml</a> osx

then run (adjust ROS distro accordingly):

$ rosdep update
$ rosdep install --from-paths src --ignore-src --rosdistro hydro -y

which should install psutil via pip.

Be sure to roll back the same file once you've done above.

edit flag offensive delete link more

Comments

I ran into the same problem - I tried your suggestion but after trying rosdep install rqt_top I get the following error rosdep install rqt_top ERROR: Rosdep cannot find all required resources to answer your query Missing resource rqt_top

JamesLloyd gravatar image JamesLloyd  ( 2013-09-20 05:00:02 -0500 )edit

I'm getting the same error on 10.8.5

meatspace_explorer gravatar image meatspace_explorer  ( 2013-09-21 13:21:35 -0500 )edit

10.7.x Same error with workaround.

manichour gravatar image manichour  ( 2013-09-22 14:33:58 -0500 )edit

Sorry, there was a couple of problems with my initial description. I've corrected my post. This worked fine for me so that I've submitted a patch to include psutil into the official rosdep key https://github.com/ros/rosdistro/pull/2187

130s gravatar image 130s  ( 2013-09-22 22:43:50 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-09-17 19:47:51 -0500

Seen: 452 times

Last updated: Sep 23 '13