Ask Your Question
2

Catkin_Make Config file Error: ros_control and ros_configuration in Hydro

asked 2013-09-16 10:58:16 -0500

ncr7 gravatar image

updated 2013-09-16 11:27:13 -0500

I'm not sure what the issue is here. I have installed everything from ROS Hydro Installation, I have Gazebo 1.9 installed correctly and installed the gazebo_ros_pkg files.

I can roscd to both ros_control and ros_controllers... but I can't seem to make a catkin_pkg that requires these packages?

Here is the error I am getting,

Make Error at /opt/ros/hydro/share/catkin/cmake/catkinConfig.cmake:72 (find_package):
  Could not find a configuration file for package ros_control.

  Set ros_control_DIR to the directory containing a CMake configuration file
  for ros_control.  The file will have one of the following names:

    ros_controlConfig.cmake
    ros_control-config.cmake

Call Stack (most recent call first):
  baxter_control/CMakeLists.txt:7 (find_package)


CMake Error at /opt/ros/hydro/share/catkin/cmake/catkinConfig.cmake:72 (find_package):
  Could not find a configuration file for package ros_controllers.

  Set ros_controllers_DIR to the directory containing a CMake configuration
  file for ros_controllers.  The file will have one of the following names:

    ros_controllersConfig.cmake
    ros_controllers-config.cmake

Call Stack (most recent call first):
  baxter_control/CMakeLists.txt:7 (find_package)

Any ideas as to what would cause this problem?

edit retag flag offensive close merge delete

Comments

1

did you try: sudo apt-get install ros-hydro-ros-control

hsu gravatar image hsu  ( 2014-02-13 10:42:07 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-09-16 11:26:40 -0500

ncr7 gravatar image

I modified the CMakeLists.txt file and it seems to now be able to build with catkin_make. I have tested that this does work, not sure why this would break initally by specifying required packages.

Modified this Line,

find_package(catkin REQUIRED COMPONENTS ros_control ros_controllers)

to this,

find_package(catkin REQUIRED COMPONENTS)
edit flag offensive delete link more

Comments

I had the same problem, and this fixed it. But WHY does this happen? Catkin should be able to find ros_control, right? Is it a configuration error from out part?

Rasmus gravatar image Rasmus  ( 2013-09-27 00:25:09 -0500 )edit

Not sure really why REQUIRED COMPONENTS portion in the CMakeLists.txt, I decided to test not using it because I know packages are also linked through package.xml. I figure there is some sort of linking error, but that is just a hypothesis... haven't really looked into it.

ncr7 gravatar image ncr7  ( 2013-09-30 19:18:57 -0500 )edit

I was getting the same error but my /opt/ros/hydro/share/ros_control folder only contains a package.xml file By removing the line from the find_package() I would have thought you're just making the compiler not look for it. You may just need to use the lower packages, ie forget ros_control?

PeterMilani gravatar image PeterMilani  ( 2013-10-10 03:18:17 -0500 )edit

Which CMakeList.txt you mean? I'm getting same error, but this solution is not working, because my CMakeLists does not have line find_package(catkin REQUIRED COMPONENTS ros_control ros_controllers). Although whole packege is freshly copied from github

pawel gravatar image pawel  ( 2014-01-26 19:19:03 -0500 )edit

I mean the CMakeLists.txt that is in the package you created using for example; 'catkin_create_pkg beginner_tutorials ros_control ros_controllers', not the CMakeLists.txt's in your ros_control and ros_controller packages. I'm not sure this is your issue though if your not making a depends package.

ncr7 gravatar image ncr7  ( 2014-02-13 10:22:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2013-09-16 10:58:16 -0500

Seen: 2,190 times

Last updated: Sep 16 '13