Ask Your Question
0

Schunk PowerCube Initialization

asked 2013-08-29 08:41:59 -0500

vandyhenry gravatar image

Hi, we are now using Schunk_bringup package to control a PowerCube Arm. After launch the nodes using: roslaunch Schunk_bringup lwa_solo.launch, I enter "rosservice call /arm_controller/init" to initialize the arm. However, it returns the error code 209, saying that module 0 cannot be reset during init. The CAN interface we are using is the ESD-PCI331 card.

Could you give me any information?

Thanks

edit retag flag offensive close merge delete

Comments

hi, did you get an answer? I also will be working on it once I m done with the installation I am actually trying to install to make them work. I use Ubuntu 12.04 - ros fuerte I wasnt able to follow the documentation, can you help me?

akrv gravatar image akrv  ( 2013-11-22 06:46:27 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-02-14 02:34:15 -0500

akrv gravatar image

Hi, My configuration: Schunk Lwa3 - 7 DOF - All Rotary joints ESD CAN PCI 331 - 3.9.4 Driver Version - Kernel 3.8 ROS Fuerte - Ubuntu 12.04 LTS I also got error code 209 while starting the schunk_modular_robotics package with roslaunch

when i created a package depending on schunk_libm5api check CMakeLists for including ESD CAN also for compilation. In some packages it compiles only with PCAN linking target library to lib/schunk_libm5api/libm5api.so programming with the Powercube Programmer guide using the API It works. Will soon share the package.

edit flag offensive delete link more

Comments

Hi, I have got it work! aswinkarthik.rv@gma...

akrv gravatar image akrv  ( 2014-05-18 23:39:38 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-08-29 08:41:59 -0500

Seen: 7,766 times

Last updated: Feb 14 '14