Hokuyo UXM-30LN-PW [closed]

asked 2013-08-19 22:21:43 -0600

Abbi gravatar image

Hi, we have recently acquired one of these Hokuyo UXM-30LN-PW sensors. On the datasheet it is listed as being compatible with SCIP 2.0 (file online called: UXM-30LN-P-Technical-Specifications.pdf)

however, on running with the standard Hokuyo Node in ROS Groovy, the following error occurs:

[ERROR] [1376982769.505473236]: Exception thrown while opening Hokuyo.
Hokuyo error code returned. Cmd: RS --  Error: Hokuyo error code returned. Cmd: RS --  Error: Hokuyo error code returned. Cmd: RS --  Error: Hokuyo error cod (in hokuyo::laser::sendCmd) You may find further details at

I guessed that this was the Reset condition of the sensor, so tried the suggested steps at the bottom of the Hokuyo node troubleshooting page, by running:

sudo ./upgrade /dev/ttyACM0 reset.cmd

however this also did not help (the same error message occurs). I have looked in other places but I cant see any other mention of someone using this laser in ROS. Can anyone help?!

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2017-11-30 13:21:07.157318

Comments

What do you get, when you connect with a terminal (like gtkterm) and issue the V-command - type 'V' (or 'VV', can't remember)?

dornhege gravatar image dornhege  ( 2013-08-19 22:50:37 -0600 )edit

I don't know about this specific sensor, but the protocol seems to be correct at least.

dornhege gravatar image dornhege  ( 2013-08-20 01:18:19 -0600 )edit

Same problem... has anyone found a way to get rid of this error?

cvcook gravatar image cvcook  ( 2015-07-11 10:13:00 -0600 )edit