Ask Your Question
0

uvc camera nodelet for multiple HD cameras

asked 2013-08-14 04:29:20 -0500

zahid gravatar image

updated 2013-08-14 04:31:24 -0500

Hello,

I am currently trying to display the output of multiple cameras (Logitech c930e) using uvc_camera nodes in HD (1920 x 1080). For each camera, there is a dedicated monitor. All the monitors are mounted on same pc with graphic cards. My question is:

When I run the cameras separately using "guvcview" command, I can display the streaming of two cameras simultaneously on two monitors. But as I switch to HD mode at 30fps one of the camera stops displaying. However if I run the same configuration with 5fps, it works.

In order to use it under ROS framework, when I run two separate nodelets "roslaunch camera_nodelet.lauch" at HD 1920 x 1080, I get the following error for the second camera only:

[uvc_camera-2] process has died [pid 27429, exit code 255, cmd /opt/ros/groovy/lib/nodelet/nodelet load uvc_camera/CameraNodelet /camera_process __name:=uvc_camera __log:=/home/spacebot/.ros/log/612e5f9a-04c9-11e3-871b-00248c04ba14/uvc_camera-2.log]. log file: /home/spacebot/.ros/log/612e5f9a-04c9-11e3-871b-00248c04ba14/uvc_camera-2*.log

The camera_nodelet.launch file for the second camera contains:

<param name="width" type="int" value="1920" />
<param name="height" type="int" value="1080" />
<param name="fps" type="int" value="5" />
<param name="frame" type="string" value="wide_stereo" />
<param name="device" type="string" value="/dev/video1" />
<remap from="/image_raw" to="/image_raw_02"/>

Could someone please suggest or comment that what exactly is happening?

Thank you!

PS: setting parameters from command line to change image resolution haven't been helpful.

edit retag flag offensive close merge delete

Comments

Are both of your cameras connected to the same USB bus/controller? Can you try hooking them to USB ports that are on separate USB controllers?

Eric Perko gravatar imageEric Perko ( 2013-09-08 09:03:42 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-09-16 02:17:11 -0500

zahid gravatar image

Thank you Eric, I just found that it was the issue of using same USB bus. By moving one camera to other USB bus solved the issue of the HD video streaming. I guess "guvcview" was inherently adjusting the frame rate and the resolution whereas running "rosrun uvc_camera camera_node" command simply started both cameras with HD and due to USB limits, one of the camera output crashed.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2013-08-14 04:29:20 -0500

Seen: 1,357 times

Last updated: Sep 16 '13