Phidgets: No Interface Kit Support Anymore? [closed]

asked 2013-08-05 08:43:11 -0600

joe.s gravatar image

updated 2013-08-05 09:00:36 -0600

I have used the Phidget Interface Kit 8/8/8 in the past to acquire Flexifoce force sensor data. It worked great!
I recently installed the newest version of the Phidget software from here: http://www.ros.org/wiki/phidgets It seems like the interface kit is no longer has a launch file.
EDIT:
I found the "interface_kit" and "interface_kit_client" files in the "bin" directory. When I run the command:
"rosrun phidgets interface_kit" I receive the error:
WARN: libusb_open failed in CUSBBuildList with error code: -3 INFO: This usually means you need to run as root, or install the udev rules.
I've run the command sudo chown 'username' /dev/ttyUSB0, as I expected the Interface Kit to be attached there (I can see the interface kit when running the 'lsusb' command), but received an error saying that ''/dev/TTYUSB0' doesn't exist'. Which, ok, that makes sense after looking up what is "under" /dev.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2013-08-05 14:06:51

Comments

Ok. Strange. But I re-ran the 'rosrun phidgets interface_kit' command and started to see output. I don't know what changed...

joe.s gravatar imagejoe.s ( 2013-08-05 10:53:28 -0600 )edit