Ask Your Question
0

android tutorial pubsub don't work

asked 2013-08-04 12:06:07 -0500

mrpiccolo gravatar image

updated 2013-08-04 12:06:46 -0500

Hi,
I installed rosjava_core and android_core in my ros groovy pc, then i followed the tutorials and i tried the android_camera tutorial app which works fine.
Now i tried the android_tutorial_pubsub app because i must write an app which publish a string but it does't work. I followed this procedure:

$ roscd android_core
$ android update project --path ./android_tutorial_pubsub/ --target android-17
$ cd android_tutorial_pubsub
$ ../gradlew debug
$ adb -d install -r ./bin/MainActivity-debug.apk
$ roscore &
$ rosrun roscpp_tutorials listener

but it does't subscribe to anything. What is the issue?

edit retag flag offensive close merge delete

Comments

What about rostopic list? Before running the last command (rosrun roscpp_tutorials listener), "chatter" appears there in the topics list? If so, are you sure that there aren't some kind of network issues?

yigit gravatar image yigit  ( 2013-08-04 23:02:50 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-08-06 08:55:07 -0500

mrpiccolo gravatar image

I resolved. There was an error in the source code, the nodeconfiguration was private, but to comunicate whit the pc must be public. thanks

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-08-04 12:06:07 -0500

Seen: 569 times

Last updated: Aug 04 '13