Ask Your Question
0

catkin_make turotial error

asked 2013-07-18 05:21:46 -0500

Manolis gravatar image

Hi all,

I was going through the ROS tutorials. After making the catkin workspace:

$ mkdir -p ~/catkin_ws/src
$ cd ~/catkin_ws/src
$ catkin_init_workspace

I try to run catkin_make as explained in tutorial:

$ cd ~/catkin_ws/
$ catkin_make

How ever I got an error msg :

ImportError: "from catkin_pkg.topological_order import topological_order" failed: No module named cmake Make sure that you have installed "catkin_pkg", it is up to date and on the PYTHONPATH.

python-catkin-pkg is installed and up-to-date. Also when I run $PYTHONPATH I get: bash: /opt/ros/groovy/lib/python2.7/dist-packages: Is a directory

I removed and reinstall ROS but didnt have any effect. I use ROS groovy and ubuntu 12.04.

How I fix this? Thanks

edit retag flag offensive close merge delete

Comments

Did you install ROS using apt-get?

gustavo.velascoh gravatar image gustavo.velascoh  ( 2013-07-18 06:26:18 -0500 )edit

Which tutorial are you doing? What ones have you already done?

tfoote gravatar image tfoote  ( 2013-07-18 11:32:22 -0500 )edit

I have done the old beginner tutorials and now I am going through new beginner tutorials with catkin. Yes I have installed ROS using apt-get

Manolis gravatar image Manolis  ( 2013-07-18 11:50:05 -0500 )edit
1

Is this the tutorial you are doing? http://www.ros.org/wiki/groovy/Installation/Ubuntu. Have you initialized rosdep and source setup.bash?

gustavo.velascoh gravatar image gustavo.velascoh  ( 2013-07-18 15:50:07 -0500 )edit

Gustav, yes , I started from the installation and then gone to tutorials. I have initialized rosdep and sourced the setup.bash. Also I run rosdep update. but I get this: ERROR: unable to process source [https://github.com/ros/rosdistro/raw/master/releases/groovy.yaml]:

Manolis gravatar image Manolis  ( 2013-07-19 05:00:56 -0500 )edit

Failed to download target platform data for gbpdistro: HTTP Error 404: Not Found

Manolis gravatar image Manolis  ( 2013-07-19 05:05:48 -0500 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2013-07-23 04:18:46 -0500

Manolis gravatar image

Since I couldn’t find any other solution I just removed Linux partition and reinstalled everything (Ubuntu 12.04, ROS etc). Now it works.

edit flag offensive delete link more
0

answered 2013-07-19 16:49:16 -0500

Hi, for your rosdep issue see this question.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-07-18 05:21:46 -0500

Seen: 1,299 times

Last updated: Jul 23 '13