Got error during the phase of Building ROS Base on Mac [closed]

asked 2013-07-14 04:21:34 -0500

Haojun Guan gravatar image

updated 2014-01-28 17:17:15 -0500

ngrennan gravatar image

I tried to install ros groovy on OS 10.8, everything was fine until i run wstool init -j8 ~/groovy_underlay

And got the error: ERROR: Cannot find required rosinstall library version, check your installation (also of vcstools) is up-to-date. One frequent cause is that rosinstall 0.5 is still installed in /usr/local/lib. No module named wstool.wstool_cli

and i have check the version of rosinstall i got, it is 0.6.29

Anyone can kindly help?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2017-07-25 16:57:54.530574


What happens if you do this: python -c "import rosinstall; print rosinstall.__version__"?

William gravatar image William  ( 2013-07-14 07:47:59 -0500 )edit

Traceback (most recent call last): File "<string>", line 1, in <module> ImportError: No module named rosinstall

Haojun Guan gravatar image Haojun Guan  ( 2013-07-16 04:46:58 -0500 )edit

Then you do not have rosinstall installed, have you done sudo pip install -U rosinstall?

William gravatar image William  ( 2013-07-16 07:11:35 -0500 )edit

Sorry that should be python -c "from rosinstall.__version__ import version; print version", but still it looks like your default Python instance cannot find rosinstall.

William gravatar image William  ( 2013-07-16 08:15:23 -0500 )edit