Ask Your Question
0

how to edit CMakeLists.txt with my program using package "create_node" ?

asked 2013-07-14 02:45:11 -0500

n gravatar image

updated 2013-07-15 06:49:06 -0500

my program will use the package: create_node, my cpp file: #include <create_mode turtlebotsebsorstate.h="">

I think I need edit CMakeLists.txt to let catkin know i will use it but i don't know what place I need write it and what should I write

is it in #Build# tag? or other place ?

===================

big thanks tbh for point the typo and help me :) after I tried add create_node to find_package and catkin_package like this:

find_package(catkin REQUIRED COMPONENTS create_node roscpp rospy std_msgs)

catkin_package(
   INCLUDE_DIRS include
   CATKIN_DEPENDS roscpp rospy std_msgs create_node)

when I use command catkin_make , it's the error message:

-- +++ processing catkin package: 'bump_sensor'
-- ==> add_subdirectory(bump_sensor)
CMake Error at /opt/ros/groovy/share/catkin/cmake/catkinConfig.cmake:72 (find_package):
  Could not find a configuration file for package create_node.

  Set create_node_DIR to the directory containing a CMake configuration file
  for create_node.  The file will have one of the following names:

    create_nodeConfig.cmake
    create_node-config.cmake

Call Stack (most recent call first):
  bump_sensor/CMakeLists.txt:8 (find_package)


-- +++ processing catkin package: 'movement'
-- ==> add_subdirectory(movement)
-- Configuring incomplete, errors occurred!
make: *** [cmake_check_build_system] Error 1
Invoking "make cmake_check_build_system" failed

is it means can not find the package create_node? or my CMakeLists.txt still not complete ? :/

edit retag flag offensive close merge delete

Comments

What version of create_node are you using? How did you install it? The master branch of https://github.com/turtlebot/turtlebot_create still uses rosbuild. The hydro-devel branch appears to use catkin.

joq gravatar imagejoq ( 2013-07-15 08:59:48 -0500 )edit

I am using groovy version

n gravatar imagen ( 2013-07-28 20:25:41 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-07-29 15:15:33 -0500

joq gravatar image

A catkin package may not depend on a rosbuild one.

Since you are using Groovy, and that create_node release still uses rosbuild, your catkin package cannot refer to it. In Hydro that will probably work. Meanwhile, you'll need to maintain your program in a rosbuild package.

edit flag offensive delete link more

Comments

i got it. thank you

n gravatar imagen ( 2013-07-29 16:14:31 -0500 )edit
0

answered 2013-07-15 04:32:58 -0500

tbh gravatar image

Have a look here. In the package that's using create_node, you'll need something like:

find_package(catkin REQUIRED COMPONENTS create_node ...)

and

catkin_package(CATKIN_DEPENDS create_node ...)

You also have a typo. Make sure you say create_node instead of create_mode.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-07-14 02:45:11 -0500

Seen: 1,673 times

Last updated: Jul 29 '13