rosserial_arduino works at 57600, but not at 9600 [closed]

asked 2013-07-09 20:44:08 -0500

Steve Robbins gravatar image

Hi,

I have an arduino sketch using rosserial_ardiuno that works OK using the default speed of 57600 baud over USB cable. I'd like to run the serial over an XBee link which, at present, is 9600 baud.

I know it should be possible to get the XBee running faster, but as a first test, I tried to run the sketch and serial_node.py at 9600. Sometimes, I can get it to run for 5-10 seconds and I know the commands are accepted because I can see the arduino-driven servos responding correctly. But ultimately, the Arduino's LED comes on and commands are no longer accepted.

I've gone over the code but can't figure out what the LED signifies. Presumably something is turning it on to signal a fatal error, but I can't find the code. Help!

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2017-07-25 16:59:41.136485

Comments

What sort of topics are you trying to send? 9600 isn't much bandwidth...

fergs gravatar imagefergs ( 2013-07-10 10:16:43 -0500 )edit

I'm sending turtlesim/Velocity which is just a pair of float32s, so I don't expect a lot of bandwidth to be necessary. Moreover, during testing I'm generating them manually at a low rate.

Steve Robbins gravatar imageSteve Robbins ( 2013-07-10 15:20:46 -0500 )edit