Ask Your Question
1

Ogre undefined reference to boost, Fuerte onFedora 18

asked 2013-06-21 06:36:59 -0600

flashedarling gravatar image

updated 2016-04-20 16:21:15 -0600

130s gravatar image

I'm having issues building gazebo and ogre for a fuerte install on Fedora 18. The issue is it isn't recognizing the boost library for some reason. It is installed and up to date but I get the following error.

/usr/include/boost/system/error_code.hpp:214: undefined reference to `boost::system::generic_category()'
/usr/include/boost/system/error_code.hpp:215: undefined reference to `boost::system::generic_category()'
/usr/include/boost/system/error_code.hpp:216: undefined reference to `boost::system::system_category()'
CMakeFiles/OgreXMLConverter.dir/src/tinyxml.cpp.o: In function `__static_initialization_and_destruction_0':
/usr/include/boost/system/error_code.hpp:214: undefined reference to `boost::system::generic_category()'
/usr/include/boost/system/error_code.hpp:215: undefined reference to `boost::system::generic_category()'
/usr/include/boost/system/error_code.hpp:216: undefined reference to `boost::system::system_category()'
CMakeFiles/OgreXMLConverter.dir/src/tinyxmlerror.cpp.o: In function `__static_initialization_and_destruction_0':
/usr/include/boost/system/error_code.hpp:214: undefined reference to `boost::system::generic_category()'
/usr/include/boost/system/error_code.hpp:215: undefined reference to `boost::system::generic_category()'
/usr/include/boost/system/error_code.hpp:216: undefined reference to `boost::system::system_category()'
CMakeFiles/OgreXMLConverter.dir/src/tinyxmlparser.cpp.o: In function `__static_initialization_and_destruction_0':
/usr/include/boost/system/error_code.hpp:214: undefined reference to `boost::system::generic_category()'
/usr/include/boost/system/error_code.hpp:215: undefined reference to `boost::system::generic_category()'
/usr/include/boost/system/error_code.hpp:216: undefined reference to `boost::system::system_category()'
../../lib/libOgreMain.so.1.7.3: undefined reference to `boost::thread::start_thread()'
../../lib/libOgreMain.so.1.7.3: undefined reference to `boost::this_thread::interruption_point()'
../../lib/libOgreMain.so.1.7.3: undefined reference to `boost::detail::get_tss_data(void const*)'
../../lib/libOgreMain.so.1.7.3: undefined reference to `boost::this_thread::get_id()'
../../lib/libOgreMain.so.1.7.3: undefined reference to `boost::this_thread::disable_interruption::~disable_interruption()'
../../lib/libOgreMain.so.1.7.3: undefined reference to `typeinfo for boost::detail::thread_data_base'
../../lib/libOgreMain.so.1.7.3: undefined reference to `boost::detail::get_current_thread_data()'
../../lib/libOgreMain.so.1.7.3: undefined reference to `boost::detail::thread_data_base::~thread_data_base()'
../../lib/libOgreMain.so.1.7.3: undefined reference to `boost::thread::detach()'
../../lib/libOgreMain.so.1.7.3: undefined reference to `boost::thread::hardware_concurrency()'
../../lib/libOgreMain.so.1.7.3: undefined reference to `boost::thread::join()'
../../lib/libOgreMain.so.1.7.3: undefined reference to `boost::detail::set_tss_data(void const*, boost::shared_ptr<boost::detail::tss_cleanup_function>, void*, bool)'
../../lib/libOgreMain.so.1.7.3: undefined reference to `vtable for boost::detail::thread_data_base'
../../lib/libOgreMain.so.1.7.3: undefined reference to `boost::this_thread::disable_interruption::disable_interruption()'

I've been trying to make this go away by adding -lboost_system manually to the LFLAGs section of the Makefile but that doesn't help. The libboost.so family is in /usr/libs and /usr/include/boost has all the hpp files. What can I do to get ogre to correctly find the libraries?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-06-22 21:54:21 -0600

Artem gravatar image

Make sure that your current Boost version has those symbols. I don't remember what commands are used to see the list of exported functions in Linux. On Mac it's otool -TV <library> or nm <library>. There could be a Boost version mismatch and some functions are missing. I successfully compiled Ogre with boos149. I gave up on trying building gazebo.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2013-06-21 06:36:59 -0600

Seen: 477 times

Last updated: Apr 20 '16